summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJerome Leclanche2015-06-09 14:35:40 +0200
committerJerome Leclanche2015-06-09 14:35:40 +0200
commit8338607ae04dbf467e871e1675417db5b45631d9 (patch)
tree5ff3046280353f16fa2f0cc790bd7bb3f12aa26b
downloadaur-8338607ae04dbf467e871e1675417db5b45631d9.tar.gz
Initial import from old AUR
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD37
2 files changed, 58 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..1e618ebe0104
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = libqtxdg-git
+ pkgdesc = Library providing freedesktop.org specs implementations for Qt.
+ pkgver = 1.2.0.13.gab0f65c
+ pkgrel = 1
+ url = http://lxqt.org
+ arch = i686
+ arch = x86_64
+ license = GPL2
+ makedepends = git
+ makedepends = cmake
+ makedepends = qt5-tools
+ depends = qt5-base
+ provides = libqtxdg
+ conflicts = libqtxdg-qt5-git
+ conflicts = libqtxdg
+ replaces = libqtxdg-qt5-git
+ source = git+https://github.com/lxde/libqtxdg.git
+ sha256sums = SKIP
+
+pkgname = libqtxdg-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..333cef3b88a4
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,37 @@
+# Maintainer: Jerome Leclanche <jerome@leclan.ch>
+
+_pkgname=libqtxdg
+pkgname=$_pkgname-git
+pkgver=1.2.0.13.gab0f65c
+pkgrel=1
+pkgdesc="Library providing freedesktop.org specs implementations for Qt."
+arch=("i686" "x86_64")
+url="http://lxqt.org"
+license=("GPL2")
+depends=("qt5-base")
+makedepends=("git" "cmake" "qt5-tools")
+provides=("$_pkgname")
+conflicts=("$_pkgname-qt5-git" "$_pkgname")
+replaces=("$_pkgname-qt5-git")
+source=("git+https://github.com/lxde/$_pkgname.git")
+sha256sums=("SKIP")
+
+
+pkgver() {
+ cd "$srcdir/$_pkgname"
+ git describe --always | sed "s/-/./g"
+}
+
+build() {
+ mkdir -p build
+ cd build
+ cmake "$srcdir/$_pkgname" \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_INSTALL_LIBDIR=lib
+ make
+}
+
+package() {
+ cd build
+ make DESTDIR="$pkgdir" install
+}