summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMarkus Kalb2015-05-30 23:40:16 +0200
committerMarkus Kalb2015-05-30 23:40:16 +0200
commit6b5f0d1eaf58ec6b92574681528724a0289a1455 (patch)
tree8199a736d2bd61dcf49424c9c85d509dce2a11de
downloadaur-6b5f0d1eaf58ec6b92574681528724a0289a1455.tar.gz
Initial import - Version 0.1.19-2
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD39
2 files changed, 52 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b00ef79badcc
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = libquickmail
+ pkgdesc = A library intended to give C/C++ developers a quick and easy way to send email from their applications
+ pkgver = 0.1.19
+ pkgrel = 2
+ url = http://sourceforge.net/projects/libquickmail
+ arch = i686
+ arch = x86_64
+ license = GPL3
+ source = libquickmail.tar.xz::http://sourceforge.net/projects/libquickmail/files/libquickmail-0.1.19.tar.xz/download
+ sha256sums = 9c54e9a0b9dee5b51c4c410f822766bd44c87aa6e20091c8ee5d270eec242f00
+
+pkgname = libquickmail
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8d3e1cd4d0a7
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,39 @@
+# Maintainer: Markus Kalb <mk@filmkreis.tu-darmstadt.de>
+# Contributor: Stefan Karner <stefan.karner@student.tuwien.ac.at>
+pkgname=libquickmail
+pkgver=0.1.19
+pkgrel=2
+pkgdesc="A library intended to give C/C++ developers a quick and easy way to send email from their applications"
+arch=('i686' 'x86_64')
+url="http://sourceforge.net/projects/libquickmail"
+license=('GPL3')
+groups=()
+depends=()
+makedepends=()
+optdepends=()
+provides=()
+conflicts=()
+replaces=()
+backup=()
+options=()
+install=
+changelog=
+source=("${pkgname}.tar.xz::http://sourceforge.net/projects/${pkgname}/files/${pkgname}-${pkgver}.tar.xz/download")
+noextract=()
+sha256sums=('9c54e9a0b9dee5b51c4c410f822766bd44c87aa6e20091c8ee5d270eec242f00')
+
+build() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+
+ aclocal
+ automake --add-missing
+ autoreconf
+ ./configure --prefix=/usr
+ make
+}
+
+package () {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+
+ make DESTDIR="$(readlink -f ${pkgdir})/" install
+}