summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSefa Eyeoglu2019-10-27 20:47:22 +0100
committerSefa Eyeoglu2019-10-27 20:47:22 +0100
commit078c9c0ab2b233b1d403ce4bbb2d5d6e238ffd6a (patch)
treec4e905e8c01d6271f679ff707bbffa2130fd1d6c
parent1f73bcad135eded746d23c1b54f2938b3de15b6b (diff)
downloadaur-078c9c0ab2b233b1d403ce4bbb2d5d6e238ffd6a.tar.gz
upgpkg: libquotient 0.5.2-5
Remove qmc-example packaging; Prepare for bundled qt5 olm dependency
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD12
2 files changed, 9 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6d89f73cec19..dfaf28f7d1e4 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = libquotient
pkgdesc = A Qt5 library to write cross-platform clients for Matrix
pkgver = 0.5.2
- pkgrel = 4
+ pkgrel = 5
url = https://github.com/quotient-im/libQuotient
arch = x86_64
license = LGPL2
@@ -11,6 +11,7 @@ pkgbase = libquotient
makedepends = gcc
depends = qt5-base
depends = qt5-multimedia
+ depends = libolm
provides = libquotient
conflicts = libquotient
source = libquotient::git+https://github.com/quotient-im/libQuotient.git#tag=0.5.2
diff --git a/PKGBUILD b/PKGBUILD
index d88ac7829ac3..88219a66977f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,12 +1,12 @@
# Maintainer: Sefa Eyeoglu <contact@scrumplex.net>
pkgname=libquotient
pkgver=0.5.2
-pkgrel=4
+pkgrel=5
pkgdesc="A Qt5 library to write cross-platform clients for Matrix"
arch=(x86_64)
url="https://github.com/quotient-im/libQuotient"
license=("LGPL2")
-depends=("qt5-base" "qt5-multimedia")
+depends=("qt5-base" "qt5-multimedia" "libolm")
makedepends=("git" "cmake" "make" "gcc")
provides=("libquotient")
conflicts=("libquotient")
@@ -16,6 +16,10 @@ sha512sums=("SKIP")
prepare() {
mkdir -p "$srcdir/build"
+
+ cd "$srcdir/${pkgname}"
+ git submodule init
+ git submodule update
}
build() {
@@ -24,8 +28,7 @@ build() {
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_LIBDIR=lib \
-DCMAKE_BUILD_TYPE=Release \
- -DBUILD_SHARED_LIBS=1 \
- -DQMATRIXCLIENT_INSTALL_EXAMPLE=0
+ -DBUILD_SHARED_LIBS=1
make
}
@@ -35,6 +38,5 @@ package() {
make DESTDIR="${pkgdir}" install
cd "$srcdir/${pkgname}"
- install -Dm 644 "examples/qmc-example.cpp" "${pkgdir}/usr/share/doc/${pkgname}/qmc-example.cpp"
install -Dm 644 "README.md" "${pkgdir}/usr/share/doc/${pkgname}/README.md"
}