summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlexey Andreyev2020-04-09 01:24:38 +0300
committerAlexey Andreyev2020-04-09 01:24:38 +0300
commit244d59daa70bf74f22ff71b590c64a27206692fa (patch)
tree3726c540cbbcec373a88ec5f73c3df5aa5b6de5a
parent078c9c0ab2b233b1d403ce4bbb2d5d6e238ffd6a (diff)
downloadaur-244d59daa70bf74f22ff71b590c64a27206692fa.tar.gz
Bump to 0.5.3.2
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD20
2 files changed, 11 insertions, 17 deletions
diff --git a/.SRCINFO b/.SRCINFO
index dfaf28f7d1e4..b388daedb427 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = libquotient
pkgdesc = A Qt5 library to write cross-platform clients for Matrix
- pkgver = 0.5.2
+ pkgver = 0.5.3.2
pkgrel = 5
url = https://github.com/quotient-im/libQuotient
arch = x86_64
@@ -11,11 +11,11 @@ pkgbase = libquotient
makedepends = gcc
depends = qt5-base
depends = qt5-multimedia
- depends = libolm
+ depends = qt5-olm
provides = libquotient
conflicts = libquotient
- source = libquotient::git+https://github.com/quotient-im/libQuotient.git#tag=0.5.2
- sha512sums = SKIP
+ source = libquotient::git+https://github.com/quotient-im/libQuotient.git#tag=0.5.3.2
+ sha512sums = 21d8b4840f489715676e380517880f34
pkgname = libquotient
diff --git a/PKGBUILD b/PKGBUILD
index 88219a66977f..f4735d10a67c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,28 +1,22 @@
-# Maintainer: Sefa Eyeoglu <contact@scrumplex.net>
+# Maintainer: Alexey Andreyev <aa13q@ya.ru>
+# Contributor Sefa Eyeoglu <contact@scrumplex.net>
+
pkgname=libquotient
-pkgver=0.5.2
+pkgver=0.5.3.2
pkgrel=5
pkgdesc="A Qt5 library to write cross-platform clients for Matrix"
arch=(x86_64)
url="https://github.com/quotient-im/libQuotient"
license=("LGPL2")
-depends=("qt5-base" "qt5-multimedia" "libolm")
+depends=("qt5-base" "qt5-multimedia" "qt5-olm")
makedepends=("git" "cmake" "make" "gcc")
provides=("libquotient")
conflicts=("libquotient")
source=("${pkgname}::git+https://github.com/quotient-im/libQuotient.git#tag=${pkgver}")
-sha512sums=("SKIP")
-
-
-prepare() {
- mkdir -p "$srcdir/build"
-
- cd "$srcdir/${pkgname}"
- git submodule init
- git submodule update
-}
+sha512sums=("21d8b4840f489715676e380517880f34")
build() {
+ mkdir "$srcdir/build"
cd "$srcdir/build"
cmake ../${pkgname} \
-DCMAKE_INSTALL_PREFIX=/usr \