summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSefa Eyeoglu2019-07-15 19:01:21 +0200
committerSefa Eyeoglu2019-07-15 19:01:21 +0200
commit537991c350d2922c35d154e49c89276a8b780cfc (patch)
tree1079ff3765bf3132a8c130230c9a9dc52d632f04
parent21846a3eb35bb86f3047f79093743b3b116e3e5b (diff)
downloadaur-537991c350d2922c35d154e49c89276a8b780cfc.tar.gz
upgpkg: libquotient 0.5.2-3
Fix wrong library path
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD7
2 files changed, 5 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 72d4fbb51ffb..1012fcaf18d3 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = libquotient
pkgdesc = A Qt5 library to write cross-platform clients for Matrix
pkgver = 0.5.2
- pkgrel = 2
+ pkgrel = 3
url = https://github.com/quotient-im/libQuotient
arch = x86_64
license = LGPL2
diff --git a/PKGBUILD b/PKGBUILD
index 473f4f532e8c..0608b785434a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Sefa Eyeoglu <contact@scrumplex.net>
pkgname=libquotient
pkgver=0.5.2
-pkgrel=2
+pkgrel=3
pkgdesc="A Qt5 library to write cross-platform clients for Matrix"
arch=(x86_64)
url="https://github.com/quotient-im/libQuotient"
@@ -22,15 +22,16 @@ build() {
cd "$srcdir/build"
cmake ../${pkgname} \
-DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_INSTALL_LIBDIR=lib \
-DCMAKE_BUILD_TYPE=Release \
-DQMATRIXCLIENT_INSTALL_EXAMPLE=false
- cmake --build . --target all
+ make
}
package() {
cd "$srcdir/build"
- cmake --build . --target install -- DESTDIR="${pkgdir}"
+ make DESTDIR="${pkgdir}" install
cd "$srcdir/${pkgname}"
install -Dm 644 "examples/qmc-example.cpp" "${pkgdir}/usr/share/doc/${pkgname}/qmc-example.cpp"