summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSefa Eyeoglu2019-07-15 18:52:48 +0200
committerSefa Eyeoglu2019-07-15 18:52:48 +0200
commit6106cc64f02b0bfdfcd66bbafc332bda54db3983 (patch)
treefccf08d6d608e152e876a395b0672841ad85eb94
downloadaur-6106cc64f02b0bfdfcd66bbafc332bda54db3983.tar.gz
Initial commit
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD39
2 files changed, 57 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..6768ef1412f9
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = libquotient
+ pkgdesc = A Qt5 library to write cross-platform clients for Matrix
+ pkgver = 0.5.2
+ pkgrel = 1
+ url = https://github.com/quotient-im/libQuotient
+ arch = x86_64
+ license = LGPL2
+ makedepends = git
+ makedepends = cmake
+ depends = qt5-base
+ depends = qt5-multimedia
+ provides = libquotient
+ conflicts = libquotient
+ source = libquotient::git+https://github.com/quotient-im/libQuotient.git#tag=0.5.2
+ sha512sums = SKIP
+
+pkgname = libquotient
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d78bb9560efa
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,39 @@
+# Maintainer: Sefa Eyeoglu <contact@scrumplex.net>
+pkgname=libquotient
+pkgver=0.5.2
+pkgrel=1
+pkgdesc="A Qt5 library to write cross-platform clients for Matrix"
+arch=(x86_64)
+url="https://github.com/quotient-im/libQuotient"
+license=("LGPL2")
+depends=("qt5-base" "qt5-multimedia")
+makedepends=("git" "cmake")
+provides=("libquotient")
+conflicts=("libquotient")
+source=("${pkgname}::git+https://github.com/quotient-im/libQuotient.git#tag=${pkgver}")
+sha512sums=("SKIP")
+
+
+prepare() {
+ mkdir -p "$srcdir/build"
+}
+
+build() {
+ cd "$srcdir/build"
+ cmake ../${pkgname} \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DQMATRIXCLIENT_INSTALL_EXAMPLE=false
+
+ cmake --build . --target all
+}
+
+package() {
+ cd "$srcdir/build"
+ cmake --build . --target install -- DESTDIR="${pkgdir}"
+
+ cd "$srcdir/${pkgname}"
+ install -dm 644 "examples/qmc-example.cpp" "${pkgdir}/usr/share/doc/${pkgname}/qmc-example.cpp"
+ install -dm 644 "README.md" "${pkgdir}/usr/share/doc/${pkgname}/README.md"
+ install -dm 644 "SECURITY.md" "${pkgdir}/usr/share/doc/${pkgname}/SECURITY.md"
+}