summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlexey Andreyev2020-04-18 13:42:31 +0300
committerAlexey Andreyev2020-04-18 13:42:31 +0300
commit6e09c6f657fb5dd891eb911ad6e0f5d1644494d6 (patch)
tree050ed7c61b3cbed0aad5cdfec880b2d4affed3e1
parentae1025a564a50e06bc52c821d35c23e6ad32b6dd (diff)
downloadaur-6e09c6f657fb5dd891eb911ad6e0f5d1644494d6.tar.gz
Bump version 0.6-beta1
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD15
2 files changed, 12 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0e7a3a66e9d3..546d99bb56bf 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = libquotient
pkgdesc = A Qt5 library to write cross-platform clients for Matrix
- pkgver = 0.5.3
- pkgrel = 2
+ pkgver = 0.6.beta1
+ pkgrel = 1
url = https://github.com/quotient-im/libQuotient
arch = x86_64
license = LGPL2
@@ -14,8 +14,8 @@ pkgbase = libquotient
optdepends = qt5-olm
provides = libquotient
conflicts = libquotient
- source = https://github.com/quotient-im/libQuotient/archive/0.5.3.2.tar.gz
- sha512sums = b887432ba7fb2b89c72ae5342fbd11b0066770851e8d0ea85ae4d6375bca726a5ee601c4f3d35a11fa1f2ef679ad5436917c08139e114f91516ccb370321e428
+ source = https://github.com/quotient-im/libQuotient/archive/0.6-beta1.tar.gz
+ sha512sums = 255560ee9a827ce140291859c9a7d11c718094b38a06e4555539aeda055daacd6a354e6685d67991fbbf2b407ab92b12986b854c27b81cfddb7b9b26c0e80e04
pkgname = libquotient
diff --git a/PKGBUILD b/PKGBUILD
index b0153e2d05a4..328fc2e50f78 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,8 +2,9 @@
# Contributor Sefa Eyeoglu <contact@scrumplex.net>
pkgname=libquotient
-pkgver=0.5.3
-pkgrel=2
+_archivever=0.6-beta1
+pkgver=0.6.beta1
+pkgrel=1
pkgdesc="A Qt5 library to write cross-platform clients for Matrix"
arch=(x86_64)
url="https://github.com/quotient-im/libQuotient"
@@ -13,11 +14,11 @@ optdepends=("qt5-olm")
makedepends=("git" "cmake" "make" "gcc")
provides=("libquotient")
conflicts=("libquotient")
-source=("https://github.com/quotient-im/libQuotient/archive/${pkgver}.${pkgrel}.tar.gz")
-sha512sums=("b887432ba7fb2b89c72ae5342fbd11b0066770851e8d0ea85ae4d6375bca726a5ee601c4f3d35a11fa1f2ef679ad5436917c08139e114f91516ccb370321e428")
+source=("https://github.com/quotient-im/libQuotient/archive/${_archivever}.tar.gz")
+sha512sums=("255560ee9a827ce140291859c9a7d11c718094b38a06e4555539aeda055daacd6a354e6685d67991fbbf2b407ab92b12986b854c27b81cfddb7b9b26c0e80e04")
build() {
- cd "$srcdir/libQuotient-${pkgver}.${pkgrel}/"
+ cd "$srcdir/libQuotient-${_archivever}/"
mkdir -p "build"
cd "build"
cmake .. \
@@ -30,10 +31,10 @@ build() {
}
package() {
- cd "$srcdir/libQuotient-${pkgver}.${pkgrel}/"
+ cd "$srcdir/libQuotient-${_archivever}/"
cd "build"
make DESTDIR="${pkgdir}" install
- cd "$srcdir/libQuotient-${pkgver}.${pkgrel}/"
+ cd "$srcdir/libQuotient-${_archivever}/"
install -Dm 644 "README.md" "${pkgdir}/usr/share/doc/${pkgname}/README.md"
}