summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlexey Andreyev2020-04-09 01:42:20 +0300
committerAlexey Andreyev2020-04-09 01:42:20 +0300
commitae1025a564a50e06bc52c821d35c23e6ad32b6dd (patch)
tree824b6ef5c3c373f73b941385dc0ef0a72d3dea92
parent20b5b7c6f657a24d5f5f4f5ce0fc4bb642bc523b (diff)
downloadaur-ae1025a564a50e06bc52c821d35c23e6ad32b6dd.tar.gz
Fix build error
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD14
2 files changed, 9 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index bc855d76f6f8..0e7a3a66e9d3 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -14,7 +14,7 @@ pkgbase = libquotient
optdepends = qt5-olm
provides = libquotient
conflicts = libquotient
- source = libquotient::git+https://github.com/quotient-im/libQuotient.git#tag=0.5.3
+ source = https://github.com/quotient-im/libQuotient/archive/0.5.3.2.tar.gz
sha512sums = b887432ba7fb2b89c72ae5342fbd11b0066770851e8d0ea85ae4d6375bca726a5ee601c4f3d35a11fa1f2ef679ad5436917c08139e114f91516ccb370321e428
pkgname = libquotient
diff --git a/PKGBUILD b/PKGBUILD
index c5010a079789..b0153e2d05a4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -13,13 +13,14 @@ optdepends=("qt5-olm")
makedepends=("git" "cmake" "make" "gcc")
provides=("libquotient")
conflicts=("libquotient")
-source=("${pkgname}::git+https://github.com/quotient-im/libQuotient.git#tag=${pkgver}")
+source=("https://github.com/quotient-im/libQuotient/archive/${pkgver}.${pkgrel}.tar.gz")
sha512sums=("b887432ba7fb2b89c72ae5342fbd11b0066770851e8d0ea85ae4d6375bca726a5ee601c4f3d35a11fa1f2ef679ad5436917c08139e114f91516ccb370321e428")
build() {
- mkdir "$srcdir/build"
- cd "$srcdir/build"
- cmake ../${pkgname} \
+ cd "$srcdir/libQuotient-${pkgver}.${pkgrel}/"
+ mkdir -p "build"
+ cd "build"
+ cmake .. \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_LIBDIR=lib \
-DCMAKE_BUILD_TYPE=Release \
@@ -29,9 +30,10 @@ build() {
}
package() {
- cd "$srcdir/build"
+ cd "$srcdir/libQuotient-${pkgver}.${pkgrel}/"
+ cd "build"
make DESTDIR="${pkgdir}" install
- cd "$srcdir/${pkgname}"
+ cd "$srcdir/libQuotient-${pkgver}.${pkgrel}/"
install -Dm 644 "README.md" "${pkgdir}/usr/share/doc/${pkgname}/README.md"
}