summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlexey Andreyev2020-04-23 13:12:28 +0300
committerAlexey Andreyev2020-04-23 13:12:28 +0300
commitcf6e079c38a523c2ebb09dcb024ed910d22ce117 (patch)
tree824b6ef5c3c373f73b941385dc0ef0a72d3dea92
parent6e09c6f657fb5dd891eb911ad6e0f5d1644494d6 (diff)
downloadaur-cf6e079c38a523c2ebb09dcb024ed910d22ce117.tar.gz
Revert "Bump version 0.6-beta1"
This reverts commit 6e09c6f657fb5dd891eb911ad6e0f5d1644494d6.
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD15
2 files changed, 11 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 546d99bb56bf..0e7a3a66e9d3 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = libquotient
pkgdesc = A Qt5 library to write cross-platform clients for Matrix
- pkgver = 0.6.beta1
- pkgrel = 1
+ pkgver = 0.5.3
+ pkgrel = 2
url = https://github.com/quotient-im/libQuotient
arch = x86_64
license = LGPL2
@@ -14,8 +14,8 @@ pkgbase = libquotient
optdepends = qt5-olm
provides = libquotient
conflicts = libquotient
- source = https://github.com/quotient-im/libQuotient/archive/0.6-beta1.tar.gz
- sha512sums = 255560ee9a827ce140291859c9a7d11c718094b38a06e4555539aeda055daacd6a354e6685d67991fbbf2b407ab92b12986b854c27b81cfddb7b9b26c0e80e04
+ source = https://github.com/quotient-im/libQuotient/archive/0.5.3.2.tar.gz
+ sha512sums = b887432ba7fb2b89c72ae5342fbd11b0066770851e8d0ea85ae4d6375bca726a5ee601c4f3d35a11fa1f2ef679ad5436917c08139e114f91516ccb370321e428
pkgname = libquotient
diff --git a/PKGBUILD b/PKGBUILD
index 328fc2e50f78..b0153e2d05a4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,9 +2,8 @@
# Contributor Sefa Eyeoglu <contact@scrumplex.net>
pkgname=libquotient
-_archivever=0.6-beta1
-pkgver=0.6.beta1
-pkgrel=1
+pkgver=0.5.3
+pkgrel=2
pkgdesc="A Qt5 library to write cross-platform clients for Matrix"
arch=(x86_64)
url="https://github.com/quotient-im/libQuotient"
@@ -14,11 +13,11 @@ optdepends=("qt5-olm")
makedepends=("git" "cmake" "make" "gcc")
provides=("libquotient")
conflicts=("libquotient")
-source=("https://github.com/quotient-im/libQuotient/archive/${_archivever}.tar.gz")
-sha512sums=("255560ee9a827ce140291859c9a7d11c718094b38a06e4555539aeda055daacd6a354e6685d67991fbbf2b407ab92b12986b854c27b81cfddb7b9b26c0e80e04")
+source=("https://github.com/quotient-im/libQuotient/archive/${pkgver}.${pkgrel}.tar.gz")
+sha512sums=("b887432ba7fb2b89c72ae5342fbd11b0066770851e8d0ea85ae4d6375bca726a5ee601c4f3d35a11fa1f2ef679ad5436917c08139e114f91516ccb370321e428")
build() {
- cd "$srcdir/libQuotient-${_archivever}/"
+ cd "$srcdir/libQuotient-${pkgver}.${pkgrel}/"
mkdir -p "build"
cd "build"
cmake .. \
@@ -31,10 +30,10 @@ build() {
}
package() {
- cd "$srcdir/libQuotient-${_archivever}/"
+ cd "$srcdir/libQuotient-${pkgver}.${pkgrel}/"
cd "build"
make DESTDIR="${pkgdir}" install
- cd "$srcdir/libQuotient-${_archivever}/"
+ cd "$srcdir/libQuotient-${pkgver}.${pkgrel}/"
install -Dm 644 "README.md" "${pkgdir}/usr/share/doc/${pkgname}/README.md"
}