summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCallum Parsey2023-08-18 20:37:16 +0930
committerCallum Parsey2023-08-18 20:37:16 +0930
commit4445a50d4575c9b96680384357c71ae52ab83c56 (patch)
treebd0c7dd572b2dd19b7e2e0bc6d85fd84d28a3cfe
parente4ac0757e700e06b03fcc2f88a50d8b577b77bca (diff)
downloadaur-libquotient-encryption.tar.gz
Update patchset for upstream 0.8.1 release
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD6
-rw-r--r--namespace.patch26
3 files changed, 20 insertions, 20 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ff54cf5d79a6..6254aca8f7ae 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = libquotient-encryption
pkgdesc = A Qt library to write cross-platform clients for Matrix (with experimental encryption support)
- pkgver = 0.8.0
+ pkgver = 0.8.1
pkgrel = 1
url = https://github.com/quotient-im/libQuotient
arch = x86_64
@@ -15,9 +15,9 @@ pkgbase = libquotient-encryption
depends = qt5-multimedia
depends = qtkeychain-qt5
provides = libQuotientE2EE.so=0.8-64
- source = https://github.com/quotient-im/libQuotient/archive/0.8.0/source.tar.gz
+ source = https://github.com/quotient-im/libQuotient/archive/0.8.1/source.tar.gz
source = namespace.patch
- sha256sums = 40d84c2a1ed8c57605836dd175aabd069aed33c77b6bd841391631607b8c3a76
- sha256sums = d1a40852adb19ba5ce132f1c1ff680c198e7e1cd9b2a36c2cc278907525f4d4e
+ sha256sums = 7786d7b8f46d64577f885234951d79aae2ba6823d8d2ba98acbde102fa1b43b1
+ sha256sums = 9d7b8066d1afde0c48e5c803c7c1a777368a1c00042c2af613e12f7775a88415
pkgname = libquotient-encryption
diff --git a/PKGBUILD b/PKGBUILD
index 1ceda070c601..edc646a1d6da 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Contributor: [object Object] <objekt-Objekt@proton.me>
pkgname=libquotient-encryption
-pkgver=0.8.0
+pkgver=0.8.1
pkgrel=1
pkgdesc="A Qt library to write cross-platform clients for Matrix (with experimental encryption support)"
arch=("x86_64" "aarch64")
@@ -13,8 +13,8 @@ makedepends=("cmake")
provides=("libQuotientE2EE.so=${pkgver%.*}-64")
source=("https://github.com/quotient-im/libQuotient/archive/${pkgver}/source.tar.gz"
"namespace.patch")
-sha256sums=('40d84c2a1ed8c57605836dd175aabd069aed33c77b6bd841391631607b8c3a76'
- 'd1a40852adb19ba5ce132f1c1ff680c198e7e1cd9b2a36c2cc278907525f4d4e')
+sha256sums=('7786d7b8f46d64577f885234951d79aae2ba6823d8d2ba98acbde102fa1b43b1'
+ '9d7b8066d1afde0c48e5c803c7c1a777368a1c00042c2af613e12f7775a88415')
prepare() {
# This patch makes the following changes:
diff --git a/namespace.patch b/namespace.patch
index c2756ee17649..92562b310f88 100644
--- a/namespace.patch
+++ b/namespace.patch
@@ -1,6 +1,6 @@
-diff '--color=auto' -rupN libQuotient-0.8.0.orig/cmake/QuotientConfig.cmake.in libQuotient-0.8.0/cmake/QuotientConfig.cmake.in
---- libQuotient-0.8.0.orig/cmake/QuotientConfig.cmake.in 2023-07-05 12:23:12.511208577 +0930
-+++ libQuotient-0.8.0/cmake/QuotientConfig.cmake.in 2023-07-05 12:54:04.695305929 +0930
+diff '--color=auto' -rupN libQuotient-0.8.1.orig/cmake/QuotientConfig.cmake.in libQuotient-0.8.1/cmake/QuotientConfig.cmake.in
+--- libQuotient-0.8.1.orig/cmake/QuotientConfig.cmake.in 2023-08-18 19:44:51.534674390 +0930
++++ libQuotient-0.8.1/cmake/QuotientConfig.cmake.in 2023-08-18 19:45:30.335910984 +0930
@@ -17,6 +17,6 @@ include("${CMAKE_CURRENT_LIST_DIR}/@QUOT
if (NOT QUOTIENT_FORCE_NAMESPACED_INCLUDES)
@@ -9,11 +9,11 @@ diff '--color=auto' -rupN libQuotient-0.8.0.orig/cmake/QuotientConfig.cmake.in l
+ list(APPEND _include_dir "${_include_dir}/@QUOTIENT_LIB_NAME@")
set_target_properties(@QUOTIENT_LIB_NAME@ PROPERTIES INTERFACE_INCLUDE_DIRECTORIES "${_include_dir}")
endif()
-diff '--color=auto' -rupN libQuotient-0.8.0.orig/CMakeLists.txt libQuotient-0.8.0/CMakeLists.txt
---- libQuotient-0.8.0.orig/CMakeLists.txt 2023-07-05 12:23:12.501208379 +0930
-+++ libQuotient-0.8.0/CMakeLists.txt 2023-07-05 12:40:00.568400131 +0930
-@@ -52,10 +52,12 @@ else()
- endif()
+diff '--color=auto' -rupN libQuotient-0.8.1.orig/CMakeLists.txt libQuotient-0.8.1/CMakeLists.txt
+--- libQuotient-0.8.1.orig/CMakeLists.txt 2023-08-18 19:44:51.524674072 +0930
++++ libQuotient-0.8.1/CMakeLists.txt 2023-08-18 19:49:15.123112596 +0930
+@@ -64,10 +64,12 @@ set_directory_properties(PROPERTIES
+ )
option(BUILD_WITH_QT6 "Build Quotient with Qt 6 (EXPERIMENTAL)" OFF)
+set(QUOTIENT_LIB_NAME ${PROJECT_NAME})
@@ -28,7 +28,7 @@ diff '--color=auto' -rupN libQuotient-0.8.0.orig/CMakeLists.txt libQuotient-0.8.
endif()
if (WIN32)
-@@ -355,7 +357,7 @@ install(TARGETS ${QUOTIENT_LIB_NAME} EXP
+@@ -349,7 +351,7 @@ install(TARGETS ${QUOTIENT_LIB_NAME} EXP
LIBRARY RUNTIME
ARCHIVE DESTINATION ${CMAKE_INSTALL_LIBDIR}
)
@@ -37,7 +37,7 @@ diff '--color=auto' -rupN libQuotient-0.8.0.orig/CMakeLists.txt libQuotient-0.8.
FILES_MATCHING PATTERN "*.h")
include(CMakePackageConfigHelpers)
-@@ -387,7 +389,7 @@ install(FILES
+@@ -381,7 +383,7 @@ install(FILES
"${CMAKE_CURRENT_BINARY_DIR}/${QUOTIENT_LIB_NAME}/${QUOTIENT_LIB_NAME}ConfigVersion.cmake"
DESTINATION ${CMakeFilesLocation}
)
@@ -46,9 +46,9 @@ diff '--color=auto' -rupN libQuotient-0.8.0.orig/CMakeLists.txt libQuotient-0.8.
if (WIN32)
install(FILES mime/packages/freedesktop.org.xml DESTINATION mime/packages)
-diff '--color=auto' -rupN libQuotient-0.8.0.orig/Quotient.pc.in libQuotient-0.8.0/Quotient.pc.in
---- libQuotient-0.8.0.orig/Quotient.pc.in 2023-07-05 12:23:12.501208379 +0930
-+++ libQuotient-0.8.0/Quotient.pc.in 2023-07-05 12:44:01.419228176 +0930
+diff '--color=auto' -rupN libQuotient-0.8.1.orig/Quotient.pc.in libQuotient-0.8.1/Quotient.pc.in
+--- libQuotient-0.8.1.orig/Quotient.pc.in 2023-08-18 19:44:51.524674072 +0930
++++ libQuotient-0.8.1/Quotient.pc.in 2023-08-18 19:49:41.350622982 +0930
@@ -3,8 +3,8 @@ exec_prefix=${prefix}
includedir=${prefix}/@CMAKE_INSTALL_INCLUDEDIR@
libdir=${prefix}/@CMAKE_INSTALL_LIBDIR@