summarylogtreecommitdiffstats
diff options
context:
space:
mode:
author[object Object]2023-01-09 09:48:49 -0800
committer[object Object]2023-01-09 09:48:49 -0800
commit08266bd3491791d34a4c016e2fd30721817d8fab (patch)
treebd76dc312fa5b04cc0172830b04c3c2d2d74ac88
downloadaur-08266bd3491791d34a4c016e2fd30721817d8fab.tar.gz
Initial commit
-rw-r--r--.SRCINFO22
-rw-r--r--.gitignore3
-rw-r--r--PKGBUILD40
3 files changed, 65 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..63a652871cee
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+pkgbase = libquotient-encryption
+ pkgdesc = A Qt5 library to write cross-platform clients for Matrix
+ pkgver = 0.7.0
+ pkgrel = 1
+ url = https://github.com/quotient-im/libQuotient
+ arch = x86_64
+ arch = aarch64
+ license = LGPL2
+ makedepends = git
+ makedepends = cmake
+ makedepends = make
+ makedepends = gcc
+ depends = qt5-base
+ depends = qt5-multimedia
+ depends = qtkeychain-qt5
+ depends = libolm
+ provides = libquotient
+ conflicts = libquotient
+ source = libquotient-encryption.tar.gz::https://github.com/quotient-im/libQuotient/archive/refs/tags/0.7.0.tar.gz
+ sha512sums = 6770e3caa6198a77fc33bf7edd2a34d5673e01474b639aa020af989046ff04c44ff5ce26b6418ae31fcca49cc54a147052153ed5c60706f26c177ebd57d452c5
+
+pkgname = libquotient-encryption
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..e5c8bdc18910
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,3 @@
+lib*
+pkg
+src
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..155620aa9ae1
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,40 @@
+# Maintainer: Alexey Andreyev <aa13q@ya.ru>
+# Contributor: Sefa Eyeoglu <contact@scrumplex.net>
+
+pkgname=libquotient-encryption
+pkgver=0.7.0
+pkgrel=1
+pkgdesc="A Qt5 library to write cross-platform clients for Matrix"
+arch=(x86_64 aarch64)
+url="https://github.com/quotient-im/libQuotient"
+license=("LGPL2")
+depends=("qt5-base" "qt5-multimedia" "qtkeychain-qt5" "libolm")
+makedepends=("git" "cmake" "make" "gcc")
+provides=("libquotient")
+conflicts=("libquotient")
+source=("${pkgname}.tar.gz::https://github.com/quotient-im/libQuotient/archive/refs/tags/0.7.0.tar.gz")
+sha512sums=("6770e3caa6198a77fc33bf7edd2a34d5673e01474b639aa020af989046ff04c44ff5ce26b6418ae31fcca49cc54a147052153ed5c60706f26c177ebd57d452c5")
+
+prepare() {
+ mkdir -p "build"
+}
+
+build() {
+ cd "build"
+ cmake ../"libQuotient-0.7.0" \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_INSTALL_LIBDIR=lib \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DBUILD_SHARED_LIBS=1 \
+ -DQuotient_ENABLE_E2EE=ON
+
+ make
+}
+
+package() {
+ cd "build"
+ make DESTDIR="${pkgdir}" install
+
+ cd "../libQuotient-0.7.0"
+ install -Dm 644 "README.md" "${pkgdir}/usr/share/doc/${pkgname}/README.md"
+}