summarylogtreecommitdiffstats
diff options
context:
space:
mode:
author[object Object]2023-01-30 13:39:19 -0800
committer[object Object]2023-01-30 13:39:19 -0800
commit6509232097e4eb09a02e1f90e0101276b365226b (patch)
treef8c9d2a07e93ba6d7f60124758691067b8bc9df7
parent7b75d173acf05f15576075998aa04c27ea819be1 (diff)
downloadaur-6509232097e4eb09a02e1f90e0101276b365226b.tar.gz
update to 0.7.1
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD15
2 files changed, 10 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 01962ea66c19..dd726269677e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = libquotient-encryption
pkgdesc = A Qt5 library to write cross-platform clients for Matrix, with experimental encryption support enabled
- pkgver = 0.7.0
- pkgrel = 2
+ pkgver = 0.7.1
+ pkgrel = 1
url = https://github.com/quotient-im/libQuotient
arch = x86_64
arch = aarch64
@@ -16,7 +16,7 @@ pkgbase = libquotient-encryption
depends = libolm
provides = libquotient
conflicts = libquotient
- source = libquotient-encryption.tar.gz::https://github.com/quotient-im/libQuotient/archive/refs/tags/0.7.0.tar.gz
- sha512sums = 6770e3caa6198a77fc33bf7edd2a34d5673e01474b639aa020af989046ff04c44ff5ce26b6418ae31fcca49cc54a147052153ed5c60706f26c177ebd57d452c5
+ source = libquotient-encryption.tar.gz::https://github.com/quotient-im/libQuotient/archive/refs/tags/0.7.1.tar.gz
+ sha512sums = ccfadae2710359b36f35b95cc9cefaa3dd234aa5db13a7bace6ad579c3b3e8e1338d444c499fe65d1cb1df95cb37bc56e38952a274a7dbefc48b3abf0eb08ee0
pkgname = libquotient-encryption
diff --git a/PKGBUILD b/PKGBUILD
index bea4f1d23225..67bf4cf7c5b6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,9 +1,6 @@
-# Maintainer: Alexey Andreyev <aa13q@ya.ru>
-# Contributor: Sefa Eyeoglu <contact@scrumplex.net>
-
pkgname=libquotient-encryption
-pkgver=0.7.0
-pkgrel=2
+pkgver=0.7.1
+pkgrel=1
pkgdesc="A Qt5 library to write cross-platform clients for Matrix, with experimental encryption support enabled"
arch=(x86_64 aarch64)
url="https://github.com/quotient-im/libQuotient"
@@ -12,8 +9,8 @@ depends=("qt5-base" "qt5-multimedia" "qtkeychain-qt5" "libolm")
makedepends=("git" "cmake" "make" "gcc")
provides=("libquotient")
conflicts=("libquotient")
-source=("${pkgname}.tar.gz::https://github.com/quotient-im/libQuotient/archive/refs/tags/0.7.0.tar.gz")
-sha512sums=("6770e3caa6198a77fc33bf7edd2a34d5673e01474b639aa020af989046ff04c44ff5ce26b6418ae31fcca49cc54a147052153ed5c60706f26c177ebd57d452c5")
+source=("${pkgname}.tar.gz::https://github.com/quotient-im/libQuotient/archive/refs/tags/0.7.1.tar.gz")
+sha512sums=("ccfadae2710359b36f35b95cc9cefaa3dd234aa5db13a7bace6ad579c3b3e8e1338d444c499fe65d1cb1df95cb37bc56e38952a274a7dbefc48b3abf0eb08ee0")
prepare() {
mkdir -p "build"
@@ -21,7 +18,7 @@ prepare() {
build() {
cd "build"
- cmake ../"libQuotient-0.7.0" \
+ cmake ../"libQuotient-0.7.1" \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_LIBDIR=lib \
-DCMAKE_BUILD_TYPE=Release \
@@ -35,6 +32,6 @@ package() {
cd "build"
make -j $(nproc) DESTDIR="${pkgdir}" install
- cd "../libQuotient-0.7.0"
+ cd "../libQuotient-0.7.1"
install -Dm 644 "README.md" "${pkgdir}/usr/share/doc/${pkgname}/README.md"
}