summarylogtreecommitdiffstats
diff options
context:
space:
mode:
author[object Object]2023-01-11 09:38:59 -0800
committer[object Object]2023-01-11 09:38:59 -0800
commit7b75d173acf05f15576075998aa04c27ea819be1 (patch)
tree508adb9d87ef705e9e99c632d54c93a5b557c46d
parent198ad95ea4a47ebd059bc4d99b0b7b2116e9ee01 (diff)
downloadaur-7b75d173acf05f15576075998aa04c27ea819be1.tar.gz
multithreaded compile
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD6
2 files changed, 4 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8eb621847e3d..01962ea66c19 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = libquotient-encryption
pkgdesc = A Qt5 library to write cross-platform clients for Matrix, with experimental encryption support enabled
pkgver = 0.7.0
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/quotient-im/libQuotient
arch = x86_64
arch = aarch64
diff --git a/PKGBUILD b/PKGBUILD
index 8ca368b370a2..bea4f1d23225 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgname=libquotient-encryption
pkgver=0.7.0
-pkgrel=1
+pkgrel=2
pkgdesc="A Qt5 library to write cross-platform clients for Matrix, with experimental encryption support enabled"
arch=(x86_64 aarch64)
url="https://github.com/quotient-im/libQuotient"
@@ -28,12 +28,12 @@ build() {
-DBUILD_SHARED_LIBS=1 \
-DQuotient_ENABLE_E2EE=ON
- make
+ make -j $(nproc)
}
package() {
cd "build"
- make DESTDIR="${pkgdir}" install
+ make -j $(nproc) DESTDIR="${pkgdir}" install
cd "../libQuotient-0.7.0"
install -Dm 644 "README.md" "${pkgdir}/usr/share/doc/${pkgname}/README.md"