summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorgustawho2020-09-04 21:11:58 -0600
committergustawho2020-09-04 21:11:58 -0600
commit7866032b1189e09e846637236084e914139b1334 (patch)
tree0b1e336767812620cce0a231e1f54ce5721094ec
downloadaur-7866032b1189e09e846637236084e914139b1334.tar.gz
Package added
-rw-r--r--.SRCINFO24
-rw-r--r--PKGBUILD47
-rw-r--r--org.kde.library.desktop38
3 files changed, 109 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..9793640fb591
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,24 @@
+pkgbase = library-git
+ pkgdesc = Document viewer and collection manager
+ pkgver = r23.d18e375
+ pkgrel = 1
+ url = https://invent.kde.org/maui/shelf
+ arch = x86_64
+ license = GPL3
+ makedepends = git
+ makedepends = extra-cmake-modules
+ depends = kio
+ depends = mauikit-git
+ depends = ki18n
+ depends = poppler-qt5
+ provides = library
+ provides = shelf
+ conflicts = library
+ conflicts = shelf
+ source = git+https://invent.kde.org/maui/shelf.git
+ source = org.kde.library.desktop
+ sha256sums = SKIP
+ sha256sums = 83fcaeba8bdffd1e616e2fd105da872b4d32a6f6f48d698156116b566faeab46
+
+pkgname = library-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f45205ae06ea
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,47 @@
+# Maintainer: Gustavo Castro < gustawho [ at ] gmail [ dot ] com >
+
+pkgname=library-git
+pkgver=r23.d18e375
+pkgrel=1
+pkgdesc="Document viewer and collection manager"
+arch=('x86_64')
+url="https://invent.kde.org/maui/shelf"
+license=('GPL3')
+depends=('kio' 'mauikit-git' 'ki18n' 'poppler-qt5')
+makedepends=('git' 'extra-cmake-modules')
+provides=('library' 'shelf')
+conflicts=('library' 'shelf')
+source=("git+$url.git" 'org.kde.library.desktop')
+sha256sums=('SKIP'
+ '83fcaeba8bdffd1e616e2fd105da872b4d32a6f6f48d698156116b566faeab46')
+
+pkgver() {
+ cd shelf
+ ( set -o pipefail
+ git describe --long 2>/dev/null | sed 's/\([^-]*-g\)/r\1/;s/-/./g' ||
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ )
+}
+
+prepare() {
+ cd shelf
+ mkdir build
+
+ sed -i '/ StoreList /s/^/\/\//' src/main.qml
+}
+
+build() {
+ cd shelf/build
+ qmake ..
+ make
+}
+
+package() {
+ cd shelf/build
+ install -d "$pkgdir/usr/share/icons/hicolor/scalable/apps"
+ install -d "$pkgdir/usr/share/applications"
+ install -d "$pkgdir/usr/bin"
+ install -Dm644 ../src/assets/library.svg "$pkgdir/usr/share/icons/hicolor/scalable/apps/"
+ install -Dm644 "$srcdir/org.kde.library.desktop" "$pkgdir/usr/share/applications/"
+ install -Dm755 library "$pkgdir/usr/bin/"
+}
diff --git a/org.kde.library.desktop b/org.kde.library.desktop
new file mode 100644
index 000000000000..d0baec7deacd
--- /dev/null
+++ b/org.kde.library.desktop
@@ -0,0 +1,38 @@
+[Desktop Entry]
+Name=Library
+Name[ca]=Library
+Name[ca@valencia]=Library
+Name[cs]=Library
+Name[da]=Library
+Name[de]=Library
+Name[en_GB]=Library
+Name[es]=Library
+Name[et]=Library
+Name[eu]=Library
+Name[fr]=Library
+Name[gl]=Library
+Name[it]=Library
+Name[ko]=Library
+Name[nl]=Library
+Name[nn]=Library
+Name[pl]=Library
+Name[pt]=Library
+Name[pt_BR]=Library
+Name[ru]=Library
+Name[sl]=Library
+Name[sv]=Library
+Name[uk]=Library
+Name[x-test]=xxLibraryxx
+Name[zh_TW]=Library
+Comment=Document Viewer and EBook Collection Manager
+Comment[en_GB]=Document Viewer and EBook Collection Manager
+TryExec=library
+Exec=library %U
+Terminal=false
+Type=Application
+Categories=Qt;Office;Document;
+StartupNotify=true
+Icon=library
+# Generic name with translations
+GenericName=Document Viewer
+GenericName[en_GB]=Document Viewer