summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChocobo12018-01-20 19:25:36 +0800
committerChocobo12018-01-20 19:43:17 +0800
commit4b99cb2f2467a17a38fcdd4d1703e0c21effd500 (patch)
tree11450cd9621523fb23a7069981850a5cc7d808d2
downloadaur-4b99cb2f2467a17a38fcdd4d1703e0c21effd500.tar.gz
newpkg: libraw-git 0.18.7.r211.g0df5490-1
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD43
2 files changed, 64 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..0198483c8a26
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = libraw-git
+ pkgdesc = A library for reading RAW files from digital cameras
+ pkgver = 0.18.7.r211.g0df5490
+ pkgrel = 1
+ url = https://www.libraw.org/
+ arch = i686
+ arch = x86_64
+ license = CDDL
+ license = LGPL
+ makedepends = git
+ depends = glibc
+ depends = jasper
+ depends = lcms2
+ provides = libraw
+ conflicts = libraw
+ options = staticlibs
+ source = git+https://github.com/LibRaw/LibRaw.git
+ sha256sums = SKIP
+
+pkgname = libraw-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..bced887c6c3c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,43 @@
+# Maintainer: Chocobo1 <chocobo1 AT archlinux DOT net>
+
+pkgname=libraw-git
+pkgver=0.18.7.r211.g0df5490
+pkgrel=1
+pkgdesc="A library for reading RAW files from digital cameras"
+arch=('i686' 'x86_64')
+url="https://www.libraw.org/"
+license=('CDDL' 'LGPL')
+depends=('glibc' 'jasper' 'lcms2')
+makedepends=('git')
+provides=('libraw')
+conflicts=('libraw')
+options=('staticlibs')
+source=("git+https://github.com/LibRaw/LibRaw.git")
+sha256sums=('SKIP')
+
+
+pkgver() {
+ cd "LibRaw"
+
+ _tag=$(git tag -l --sort -v:refname | head -n1)
+ _rev=$(git rev-list --count $_tag..HEAD)
+ _hash=$(git rev-parse --short HEAD)
+ printf "%s.r%s.g%s" "$_tag" "$_rev" "$_hash"
+}
+
+build() {
+ cd "LibRaw"
+
+ autoreconf --install
+ ./configure --prefix="/usr" --disable-examples
+ make
+}
+
+package() {
+ cd "LibRaw"
+
+ make DESTDIR="$pkgdir" install
+
+ rm "$pkgdir/usr/share/doc/libraw/COPYRIGHT"
+ rm "$pkgdir/usr/share/doc/libraw"/LICENSE.*
+}