summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSam Whited2018-10-01 20:18:11 -0500
committerSam Whited2018-10-01 20:20:55 -0500
commitf2b3e2ae5261dafb66a7f8604c8bf22109d6a83a (patch)
tree2ba4fa1a19c5eb8ea3abfd2f2edea6d6925f151f
parent30a012cc0311fe7fce7b95f3f3732cbf9b58b683 (diff)
downloadaur-libraw16.tar.gz
Fix non-standard docs directory
Minor package cleanup / consistency tweaks
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD40
2 files changed, 27 insertions, 21 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 13e15bb90556..42a9aace39e9 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,14 @@
pkgbase = libraw16
- pkgdesc = A library for reading RAW files obtained from digital photo cameras (CRW/CR2, NEF, RAF, DNG, and others)
+ pkgdesc = A library for reading RAW files obtained from digital cameras (CRW/CR2, NEF, RAF, DNG, and others)
pkgver = 0.18.13
- pkgrel = 0
+ pkgrel = 1
url = https://www.libraw.org/
arch = x86_64
license = CDDL
license = LGPL
- depends = lcms2
depends = jasper
- provides = libraw=0.18.13,
+ depends = lcms2
+ provides = libraw=0.18.13
provides = libraw16
source = https://www.libraw.org/data/LibRaw-0.18.13.tar.gz
sha256sums = cb1f9d0d1fabc8967d501d95c05d2b53d97a2b917345c66553b1abbea06757ca
diff --git a/PKGBUILD b/PKGBUILD
index a3ca0f923b73..8e4afd16569f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,28 +2,34 @@
pkgname=libraw16
pkgver=0.18.13
-pkgrel=0
-provides=("libraw=$pkgver", "$pkgname")
-pkgdesc="A library for reading RAW files obtained from digital photo cameras (CRW/CR2, NEF, RAF, DNG, and others)"
+pkgrel=1
+provides=("libraw=${pkgver}" "${pkgname}")
+pkgdesc='A library for reading RAW files obtained from digital cameras (CRW/CR2, NEF, RAF, DNG, and others)'
arch=('x86_64')
-url="https://www.libraw.org/"
-license=(CDDL LGPL)
-depends=(lcms2 jasper)
-source=(https://www.libraw.org/data/LibRaw-$pkgver.tar.gz)
+url='https://www.libraw.org/'
+license=(
+ 'CDDL'
+ 'LGPL'
+)
+depends=(
+ 'jasper'
+ 'lcms2'
+)
+source=("https://www.libraw.org/data/LibRaw-${pkgver}.tar.gz")
sha256sums=('cb1f9d0d1fabc8967d501d95c05d2b53d97a2b917345c66553b1abbea06757ca')
build() {
- cd LibRaw-$pkgver
- ./configure --prefix=/usr \
- --disable-examples \
- --docdir=/usr/doc/$pkgname \
- --includedir=/usr/include/libraw-$pkgver \
- --disable-static
- make
+ cd LibRaw-${pkgver}
+ ./configure --prefix=/usr \
+ --disable-examples \
+ --docdir=/usr/share/doc/${pkgname} \
+ --includedir=/usr/include/libraw-${pkgver} \
+ --disable-static
+ make
}
package() {
- cd LibRaw-$pkgver
- make DESTDIR="$pkgdir" install
- rm -rf "${pkgdir}"/usr/lib/{libraw{.a,_r.a,_r.so,.so},pkgconfig}
+ cd LibRaw-${pkgver}
+ make DESTDIR="${pkgdir}" install
+ rm -rf "${pkgdir}"/usr/lib/{libraw{.a,_r.a,_r.so,.so},pkgconfig}
}