summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNichlas Severinsen2019-05-17 13:56:11 +0200
committerNichlas Severinsen2019-05-17 13:56:11 +0200
commit436485e9fce580a351887addbae96f2b5e2c1ef3 (patch)
treed926d9f7dcdeb2a34c32d9669e9a2f5e589c17c1
downloadaur-436485e9fce580a351887addbae96f2b5e2c1ef3.tar.gz
Initial commit
-rw-r--r--.SRCINFO13
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD20
3 files changed, 37 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..2c53222fce59
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = libray-git
+ pkgdesc = LibRay aims to be a Libre (FLOSS) Python application for unencrypting, extracting, repackaging, and encrypting PS3 ISOs.
+ pkgver = 0.0.1
+ pkgrel = 1
+ arch = any
+ license = GPLv3
+ depends = python
+ depends = python-pip
+ source = https://notabug.org/necklace/libray/archive/0.0.1.tar.gz
+ sha256sums = 35d04f09d8ae019be4f62067dad19fce14aa5436e677ba22b3510b58117a5aa8
+
+pkgname = libray-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..67d748065652
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*.gz
+*.xz
+pkg/
+src/
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..16f67f1ae001
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,20 @@
+# Maintainer: Nichlas Severinsen <ns@nsz.no>
+pkgname=libray-git
+_gitname="libray"
+pkgver=0.0.1
+pkgrel=1
+pkgdesc="LibRay aims to be a Libre (FLOSS) Python application for unencrypting, extracting, repackaging, and encrypting PS3 ISOs."
+arch=("any")
+license=("GPLv3")
+depends=("python" "python-pip")
+
+source=("https://notabug.org/necklace/${_gitname}/archive/${pkgver}.tar.gz")
+
+sha256sums=("35d04f09d8ae019be4f62067dad19fce14aa5436e677ba22b3510b58117a5aa8")
+
+package() {
+ cd $srcdir/$_gitname
+ python setup.py install --root="${pkgdir}" --optimize=1
+ install -Dm644 COPYING "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}
+