summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJames Harvey2015-07-17 21:47:28 +0000
committerJames Harvey2015-07-17 21:47:28 +0000
commite69697e386a27f969f066f48ec6e4f0b4fa30e87 (patch)
tree48208f900de336c2f03be7c72b8bc93ec26aa5c7
downloadaur-e69697e386a27f969f066f48ec6e4f0b4fa30e87.tar.gz
Initial import
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD30
2 files changed, 45 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..9d2ada35141d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = librdmacm
+ pkgdesc = OpenFabrics Alliance datagram transfers over RDMA for InfiniBand and iWARP
+ pkgver = 1.0.21
+ pkgrel = 1
+ url = https://www.openfabrics.org/index.php/overview.html
+ arch = x86_64
+ arch = i686
+ license = GPL2
+ license = custom:"Open Fabrics Alliance BSD"
+ depends = libibverbs
+ source = https://www.openfabrics.org/downloads/rdmacm/librdmacm-1.0.21.tar.gz
+ md5sums = 6e9bda2f115549cde20eed29221ea0c2
+
+pkgname = librdmacm
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c2fb7ddec5d5
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: James Harvey <jamespharvey20@gmail.com>
+# * No namcap warnings or errors
+
+pkgname=librdmacm
+pkgver=1.0.21
+pkgrel=1
+pkgdesc='OpenFabrics Alliance datagram transfers over RDMA for InfiniBand and iWARP'
+arch=('x86_64' 'i686')
+url=('https://www.openfabrics.org/index.php/overview.html')
+license=('GPL2' 'custom:"Open Fabrics Alliance BSD"')
+depends=('libibverbs')
+source=("https://www.openfabrics.org/downloads/rdmacm/${pkgname}-${pkgver}.tar.gz")
+md5sums=('6e9bda2f115549cde20eed29221ea0c2')
+
+build() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ ./configure --prefix=/usr \
+ --sbindir=/usr/bin \
+ --libexecdir=/usr/lib \
+ --sysconfdir=/etc \
+ --localstatedir=/var \
+ --mandir=/usr/share/man
+ make
+}
+
+package() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ make DESTDIR="${pkgdir}" install
+ install -Dm644 COPYING "${pkgdir}/usr/share/licenses/${pkgname}/COPYING"
+}