summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJan Tulak2016-09-01 22:52:06 +0200
committerJan Tulak2016-09-01 22:52:06 +0200
commit1cd6b8a804ed88bd7593b87d702a814672b38ea1 (patch)
treed5401debc89088eaeba472ee4d7cc45625c26112
downloadaur-1cd6b8a804ed88bd7593b87d702a814672b38ea1.tar.gz
first version of PKGBUILD
Signed-off-by: Jan Tulak <jtulak@redhat.com>
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD23
2 files changed, 36 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..4218ca0e4232
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = librdrand
+ pkgdesc = A library and an userspace application (rdrand-gen) for easy access to Intel's RdRand DRNG.
+ pkgver = 2.0.0
+ pkgrel = 1
+ url = https://github.com/BroukPytlik/RdRand
+ arch = x86_64
+ license = LGPL
+ depends = openssl
+ source = https://github.com/BroukPytlik/RdRand/archive/2.0.0.tar.gz
+ md5sums = e5aa7feb2f1f21b56911c58e8faba475
+
+pkgname = librdrand
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3bf4ac29abb4
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer: Jan Tulak <jan@tulak.me>
+pkgname=librdrand
+pkgver=2.0.0
+pkgrel=1
+epoch=
+pkgdesc="A library and an userspace application (rdrand-gen) for easy access to Intel's RdRand DRNG."
+arch=("x86_64")
+url="https://github.com/BroukPytlik/RdRand"
+license=('LGPL')
+depends=('openssl')
+source=("https://github.com/BroukPytlik/RdRand/archive/$pkgver.tar.gz")
+md5sums=("e5aa7feb2f1f21b56911c58e8faba475")
+
+build() {
+ cd "RdRand-$pkgver"
+ ./configure --prefix=/usr
+ make
+}
+
+package() {
+ cd "RdRand-$pkgver"
+ make DESTDIR="$pkgdir/" install
+}