summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorzxp198210052023-09-03 09:22:19 +0800
committerzxp198210052023-09-03 09:22:19 +0800
commit0defff6ccbd78d74d7e90163256f67b863577201 (patch)
tree542a8c0718b153212b7b60c40e5af8eef33b3459
downloadaur-0defff6ccbd78d74d7e90163256f67b863577201.tar.gz
update to 1.0.4
-rw-r--r--.SRCINFO30
-rw-r--r--PKGBUILD25
2 files changed, 55 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b7e5df67fa13
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,30 @@
+pkgbase = librefancontrol-bin
+ pkgdesc = A way to control fans based on temperature
+ pkgver = 1.0.4
+ pkgrel = 1
+ url = https://github.com/wiiznokes/LibreFanControl
+ arch = x86_64
+ license = AGPL3
+ makedepends = gendesk
+ depends = glibc
+ depends = freetype2
+ depends = libxi
+ depends = gcc-libs
+ depends = libx11
+ depends = libxrender
+ depends = alsa-lib
+ depends = zlib
+ depends = libxtst
+ depends = bash
+ depends = libglvnd
+ depends = fontconfig
+ depends = java-runtime
+ depends = libxext
+ depends = i2c-tools
+ depends = aspnet-runtime
+ provides = librefancontrol=1.0.4
+ conflicts = librefancontrol
+ source = librefancontrol-1.0.4.tar.gz::https://github.com/wiiznokes/LibreFanControl/releases/download/v1.0.4/LibreFanControl.tar.gz
+ sha256sums = 8c81e811158d9ca6ee869eef813486987bc30b799d24b953916e5d472841a19a
+
+pkgname = librefancontrol-bin
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..1835318e39f2
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: zxp19821005 <zxp19821005 at 163 dot com>
+pkgname=librefancontrol-bin
+_pkgname=LibreFanControl
+pkgver=1.0.4
+pkgrel=1
+pkgdesc="A way to control fans based on temperature"
+arch=("x86_64")
+url="https://github.com/wiiznokes/LibreFanControl"
+license=('AGPL3')
+provides=("${pkgname%-bin}=${pkgver}")
+conflicts=("${pkgname%-bin}")
+depends=('glibc' 'freetype2' 'libxi' 'gcc-libs' 'libx11' 'libxrender' 'alsa-lib' 'zlib' 'libxtst' 'bash' 'libglvnd' 'fontconfig' 'java-runtime' 'libxext' 'i2c-tools' 'aspnet-runtime')
+makedepends=('gendesk')
+source=("${pkgname%-bin}-${pkgver}.tar.gz::${url}/releases/download/v${pkgver}/${_pkgname}.tar.gz")
+sha256sums=('8c81e811158d9ca6ee869eef813486987bc30b799d24b953916e5d472841a19a')
+prepare() {
+ gendesk -f -n --categories "System;Utility" --name "${_pkgname}" --exec "${pkgname}"
+}
+package() {
+ install -Dm755 -d "${pkgdir}/"{opt,etc/systemd/system,usr/bin,usr/local/bin/"${_pkgname}"Service}
+ cp -r "${srcdir}/${_pkgname}" "${pkgdir}/opt"
+ ln -sf "/opt/${_pkgname}/bin/${_pkgname}" "${pkgdir}/usr/bin/${pkgname%-bin}"
+ install -Dm644 "${srcdir}/${pkgname%-bin}.desktop" -t "${pkgdir}/usr/share/applications"
+ install -Dm644 "${srcdir}/${_pkgname}/lib/${_pkgname}.png" "${pkgdir}/usr/share/pixmaps/${pkgname%-bin}.png"
+} \ No newline at end of file