summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFelix Morgner2019-08-16 16:47:56 +0200
committerFelix Morgner2019-08-16 16:56:26 +0200
commitf1e63a502eea0589c4b967a1a5c307ff1f4bd2d5 (patch)
treea7ddb4e240c75db823b418a1cf4895ba62218885
downloadaur-f1e63a502eea0589c4b967a1a5c307ff1f4bd2d5.tar.gz
initial commit
-rw-r--r--.SRCINFO13
-rw-r--r--.gitignore3
-rw-r--r--51-librem-key.rules1
-rw-r--r--PKGBUILD18
-rw-r--r--librem-key-udev.install16
5 files changed, 51 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f699d6affe5e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = librem-key-udev
+ pkgdesc = Udev rules to allow the wheel group access to the Librem Key
+ pkgver = 1.0.0
+ pkgrel = 1
+ install = librem-key-udev.install
+ arch = any
+ license = GPL2
+ depends = systemd
+ source = 51-librem-key.rules
+ md5sums = ffae0fb25bc851a4a0c062a88b1930f4
+
+pkgname = librem-key-udev
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..6792c8f74235
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,3 @@
+/pkg
+/src
+*.pkg.tar.xz
diff --git a/51-librem-key.rules b/51-librem-key.rules
new file mode 100644
index 000000000000..8b46b1d00dd5
--- /dev/null
+++ b/51-librem-key.rules
@@ -0,0 +1 @@
+SUBSYSTEM=="usb", ATTR{idVendor}=="316d", ATTR{idProduct}=="4c4b", GROUP="wheel" #, MODE="0666"
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..160546acf498
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,18 @@
+# Maintainer: Felix Morgner <felix.morgner@gmail.com
+
+pkgname=librem-key-udev
+pkgver=1.0.0
+pkgrel=1
+pkgdesc='Udev rules to allow the wheel group access to the Librem Key'
+arch=('any')
+license=('GPL2')
+source=('51-librem-key.rules')
+depends=('systemd')
+install='librem-key-udev.install'
+md5sums=('ffae0fb25bc851a4a0c062a88b1930f4')
+
+package() {
+ mkdir -p $pkgdir/usr/lib/udev/rules.d/
+ cp 51-librem-key.rules $pkgdir/usr/lib/udev/rules.d/
+ chmod a+r $pkgdir/usr/lib/udev/rules.d/51-librem-key.rules
+}
diff --git a/librem-key-udev.install b/librem-key-udev.install
new file mode 100644
index 000000000000..6228192a6b95
--- /dev/null
+++ b/librem-key-udev.install
@@ -0,0 +1,16 @@
+post_install() {
+ udevadm control --reload
+cat << EOF
+===> If you have troubles accessing the Librem Key, make sure to:
+===> - restart scdaemon
+===> - add your user to the 'wheel' group
+EOF
+}
+
+post_upgrade() {
+ udevadm control --reload
+}
+
+post_remove() {
+ udevadm control --reload
+}