summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBollos002021-03-29 18:24:12 -0300
committerBollos002021-03-29 18:24:12 -0300
commitaeed586ff0d7ed0523de8bb3c0e163ac7eebcbe7 (patch)
tree1230fe12d6fb4635222389ce7beb59e125a2e144
downloadaur-aeed586ff0d7ed0523de8bb3c0e163ac7eebcbe7.tar.gz
LibreMines 1.4.0 on AUR
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD29
2 files changed, 47 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..5ae9939f46ef
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = libremines
+ pkgdesc = A Free/Libre and Open Source Software Qt based Minesweeper game available for GNU/Linux and FreeBSD
+ pkgver = 1.4.0
+ pkgrel = 1
+ url = https://github.com/Bollos00/LibreMines
+ arch = x86_64
+ license = GPL3
+ makedepends = cmake
+ depends = qt5-base
+ depends = hicolor-icon-theme
+ depends = qt5-svg
+ provides = libremines
+ conflicts = libremines
+ source = LibreMines-1.4.0.tar.gz::https://github.com/Bollos00/LibreMines/archive/refs/tags/v1.4.0.tar.gz
+ sha256sums = 5b444f75b079e5b0e4e1abe2410394bd8b2d2db67c35d2f804d7e174f39abae8
+
+pkgname = libremines
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a1e7bac7c4f0
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: Bruno Bollos Correa <bollos@outlook.com.br>
+pkgname=libremines
+
+pkgver=1.4.0
+pkgrel=1
+pkgdesc="A Free/Libre and Open Source Software Qt based Minesweeper game available for GNU/Linux and FreeBSD"
+arch=('x86_64')
+url="https://github.com/Bollos00/LibreMines"
+license=('GPL3')
+groups=()
+depends=('qt5-base' 'hicolor-icon-theme' 'qt5-svg')
+makedepends=('cmake')
+provides=('libremines')
+conflicts=('libremines')
+source=("LibreMines-$pkgver.tar.gz::https://github.com/Bollos00/LibreMines/archive/refs/tags/v$pkgver.tar.gz")
+sha256sums=('5b444f75b079e5b0e4e1abe2410394bd8b2d2db67c35d2f804d7e174f39abae8')
+
+
+build() {
+ cd $srcdir/LibreMines-$pkgver
+ mkdir builddir && cd builddir
+ cmake -DCMAKE_INSTALL_PREFIX=/usr ..
+ make
+}
+
+package() {
+ cd $srcdir/LibreMines-$pkgver/builddir
+ make DESTDIR="$pkgdir" install
+}