summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMohamed Amine Zghal2025-02-24 16:12:02 +0100
committerMohamed Amine Zghal2025-02-24 16:12:02 +0100
commite9cc4496594f75d6eeaf35900211aaa2d79c429f (patch)
treef4a6978c8cfba5936d7717b7eced1a1991bb08ec
downloadaur-e9cc4496594f75d6eeaf35900211aaa2d79c429f.tar.gz
Initial commit
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD19
2 files changed, 31 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..002b4ecc4d86
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,12 @@
+pkgbase = libreoffice-extension-citequran
+ pkgdesc = CiteQuran is a LibreOffice extension that allows you to Cite the Holy Quran in your Writer document without errors and with proper Arabic fonts.
+ pkgver = 3.0
+ pkgrel = 1
+ url = https://github.com/cdjalel/CiteQuran
+ arch = any
+ license = GPL-3.0
+ depends = libreoffice
+ source = https://github.com/cdjalel/CiteQuran/releases/download/v3.0/CiteQuran-v3.0.oxt
+ sha256sums = 2dcf2ca555277bc7a6cb77778dd24233dee37de8edb534f1fa31f00ca2875291
+
+pkgname = libreoffice-extension-citequran
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..654dca2c2ae1
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,19 @@
+# Maintainer: Mohamed Amine Zghal (medaminezghal) <medaminezghal at outlook dot com>
+
+_name=CiteQuran
+pkgname=libreoffice-extension-${_name,,}
+pkgver=3.0
+pkgrel=1
+pkgdesc="CiteQuran is a LibreOffice extension that allows you to Cite the Holy Quran in your Writer document without errors and with proper Arabic fonts."
+arch=('any')
+url="https://github.com/cdjalel/CiteQuran"
+license=('GPL-3.0')
+depends=('libreoffice')
+source=("${url}/releases/download/v${pkgver}/${_name}-v${pkgver}.oxt")
+sha256sums=('2dcf2ca555277bc7a6cb77778dd24233dee37de8edb534f1fa31f00ca2875291')
+
+package () {
+ install -d "$pkgdir/usr/lib/libreoffice/share/extensions/"
+ cp -R "$srcdir" "$pkgdir/usr/lib/libreoffice/share/extensions/$_name"
+ rm -f "$pkgdir/lib/libreoffice/share/extensions/cooder/${_name}-${pkgver}.oxt"
+}