summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAskhat2018-05-09 12:17:37 +0700
committerAskhat2018-05-09 12:17:37 +0700
commitd788e8765a69d9194ffba519504e38de7376d569 (patch)
tree1bf15893d1ef780857ef3ee3b4bc9301a448ddf8
downloadaur-d788e8765a69d9194ffba519504e38de7376d569.tar.gz
Initial commit
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD24
2 files changed, 41 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..10152d36ead2
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+# Generated by mksrcinfo v8
+# Wed May 9 05:13:17 UTC 2018
+pkgbase = libreoffice-extension-formatting-math-formulas
+ pkgdesc = This extension allows formatting of all (or selected) Math formulas in your document. Works in Writer, Calc, Draw and Impress.
+ pkgver = 0.1.6
+ pkgrel = 1
+ url = https://extensions.libreoffice.org/extensions/formatting-of-all-math-formulas
+ arch = any
+ groups = libreoffice-extensions
+ license = MIT
+ depends = libreoffice
+ noextract = FAF-0.1.6.oxt
+ source = https://extensions.libreoffice.org/extensions/formatting-of-all-math-formulas/0-1.6/@@download/file/FAF-0.1.6.oxt
+ sha512sums = cfc5920faa7b07a660d657e1d1f85d10408135877ccaa49ee5ebebde17abe5747993da13fc7394970c6d644a9ea2e54458c995a04ad384226359dcf42448b44a
+
+pkgname = libreoffice-extension-formatting-math-formulas
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..11d935af2e99
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+#
+pkgname=libreoffice-extension-formatting-math-formulas
+_pkgname=faf
+pkgver=0.1.6
+pkgrel=1
+pkgdesc="This extension allows formatting of all (or selected) Math formulas in your document. Works in Writer, Calc, Draw and Impress."
+arch=('any')
+url="https://extensions.libreoffice.org/extensions/formatting-of-all-math-formulas"
+license=('MIT')
+groups=('libreoffice-extensions')
+depends=(libreoffice)
+noextract=("FAF-${pkgver}.oxt")
+source=(https://extensions.libreoffice.org/extensions/formatting-of-all-math-formulas/0-1.6/@@download/file/FAF-0.1.6.oxt)
+sha512sums=('cfc5920faa7b07a660d657e1d1f85d10408135877ccaa49ee5ebebde17abe5747993da13fc7394970c6d644a9ea2e54458c995a04ad384226359dcf42448b44a')
+
+package() {
+
+ _DESTDIR="${pkgdir}/usr/lib/libreoffice/share/extensions/${_pkgname}/"
+ install -dm755 "${_DESTDIR}"
+ bsdtar -xf FAF-${pkgver}.oxt -C "${_DESTDIR}"
+ chmod -R a=r,a+X,u+w "${_DESTDIR}"
+
+}
+