summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorEnrico Lovisotto2015-06-09 15:12:15 +0200
committerEnrico Lovisotto2015-06-09 15:12:15 +0200
commit762a9ed7d3bbe2e27892a30f6e867944d73d374d (patch)
tree0d359cac97b818ea6d4eec8ed50f37980e0ca164
downloadaur-762a9ed7d3bbe2e27892a30f6e867944d73d374d.tar.gz
Initial Import
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD21
2 files changed, 36 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c74a0d3be1ee
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = libreoffice-extension-perfectepub
+ pkgdesc = Extension for cleaning formatting errors in LibO files
+ pkgver = 0.0.7
+ pkgrel = 2
+ url = http://lukesblog.it/ebooks/ebook-tools/perfectepub/
+ arch = any
+ groups = libreoffice-extensions
+ license = LGPL
+ depends = libreoffice
+ depends = java-runtime
+ source = http://lukesblog.it/wp-content/plugins/cimy-counter/cc_redirect.php?cc=PerfectEpub&fn=http://dl.dropbox.com/u/14712909/macro/PerfectEpub/PerfectEpub-0.0.7.oxt
+ md5sums = c62ce487234fe927cd2bae3fb653a7f4
+
+pkgname = libreoffice-extension-perfectepub
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b24c6407576f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,21 @@
+pkgname=libreoffice-extension-perfectepub
+_pkgname=PerfectEpub
+pkgver=0.0.7
+pkgrel=2
+pkgdesc="Extension for cleaning formatting errors in LibO files"
+arch=('any')
+url="http://lukesblog.it/ebooks/ebook-tools/perfectepub/"
+license=('LGPL')
+groups=('libreoffice-extensions')
+depends=('libreoffice' 'java-runtime')
+source=('http://lukesblog.it/wp-content/plugins/cimy-counter/cc_redirect.php?cc=PerfectEpub&fn=http://dl.dropbox.com/u/14712909/macro/PerfectEpub/PerfectEpub-0.0.7.oxt')
+md5sums=('c62ce487234fe927cd2bae3fb653a7f4')
+
+package() {
+ mkdir -p "$pkgdir/usr/lib/libreoffice/share/extensions/$_pkgname/"
+ cp -R "$srcdir"/* "$pkgdir/usr/lib/libreoffice/share/extensions/$_pkgname/"
+ rm "$pkgdir/usr/lib/libreoffice/share/extensions/$_pkgname/$_pkgname-$pkgver.oxt"
+}
+
+
+