summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJonas Heinrich2017-01-22 20:31:30 +0100
committerJonas Heinrich2017-01-22 20:31:30 +0100
commit1ed5ed3328a68ef87edc32806de43f633b3f4562 (patch)
treead58523542fd238d164ff3df05f00c69a95b97dd
downloadaur-1ed5ed3328a68ef87edc32806de43f633b3f4562.tar.gz
first commit
-rw-r--r--.SRCINFO25
-rw-r--r--PKGBUILD41
-rw-r--r--libreoffice-online.install12
-rw-r--r--loolwsd.service12
4 files changed, 90 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..db1bf9e45e16
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,25 @@
+# Generated by mksrcinfo v8
+# Sun Jan 22 19:31:21 UTC 2017
+pkgbase = libreoffice-online
+ pkgdesc = HTML5-based/cloud-based version of the office suite
+ pkgver = 2.0.2
+ pkgrel = 1
+ url = https://cgit.freedesktop.org/libreoffice/online/
+ install = libreoffice-online.install
+ arch = x86_64
+ license = MPL
+ makedepends = cppunit
+ makedepends = poco
+ makedepends = libreoffice
+ depends = libpng12
+ depends = poco
+ depends = pcre
+ source = git+https://github.com/LibreOffice/core.git
+ source = libreoffice-online-2.0.2-3.tar.gz::https://github.com/LibreOffice/online/archive/2.0.2-3.tar.gz
+ source = loolwsd.service
+ sha512sums = SKIP
+ sha512sums = a0c2084fbd14b01a344ca4a8839ac75ea3c9e35d05a2dea8a2f93d98c6ff22f891367069c8c9fe4a48ee1ffd17ff6ddf15ac61e4cafbc9e1ef0aff32963cb5ff
+ sha512sums = 71fd3aec864b1f084dafc602a7fadc91fed146b57dba8cacc7bc277a42f197616a6a43c07d13e2e74a604166cd691a81f5c7de447ddecb680919e3f6b451adb6
+
+pkgname = libreoffice-online
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7c51ab50d727
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,41 @@
+# Maintainer: Jonas Heinrich <onny@project-insanity.org>
+# Contributor: Jonas Heinrich <onny@project-insanity.org>
+
+pkgname=libreoffice-online
+pkgver=2.0.2
+pkgrel=1
+pkgdesc="HTML5-based/cloud-based version of the office suite"
+arch=("x86_64")
+url="https://cgit.freedesktop.org/libreoffice/online/"
+license=("MPL")
+makedepends=("cppunit" "poco" "libreoffice")
+depends=("libpng12" "poco" "pcre")
+install="libreoffice-online.install"
+
+source=("git+https://github.com/LibreOffice/core.git"
+ "${pkgname}-${pkgver}-3.tar.gz::https://github.com/LibreOffice/online/archive/${pkgver}-3.tar.gz"
+ "loolwsd.service")
+sha512sums=('SKIP'
+ 'a0c2084fbd14b01a344ca4a8839ac75ea3c9e35d05a2dea8a2f93d98c6ff22f891367069c8c9fe4a48ee1ffd17ff6ddf15ac61e4cafbc9e1ef0aff32963cb5ff'
+ '71fd3aec864b1f084dafc602a7fadc91fed146b57dba8cacc7bc277a42f197616a6a43c07d13e2e74a604166cd691a81f5c7de447ddecb680919e3f6b451adb6')
+
+build() {
+ cd "${srcdir}/online-${pkgver}-3"
+ ./autogen.sh
+ ./configure --enable-silent-rules \
+ --with-lokit-path=${srcdir}/core/include \
+ --with-lo-path=/usr/lib/libreoffice \
+ --prefix=/
+ #./configure --enable-silent-rules --with-lokit-path=/usr/include/libreoffice --with-lo-path=/usr/lib/libreoffice
+ make
+}
+
+package() {
+ cd "${srcdir}/online-${pkgver}-3"
+ make DESTDIR=${pkgdir} install
+ install -Dm644 "${srcdir}/loolwsd.service" "${pkgdir}/usr/lib/systemd/system/loolwsd.service"
+ mv ${pkgdir}/bin ${pkgdir}/share ${pkgdir}/usr/
+ mkdir -p "${pkgdir}/var/lib/lool"
+ mkdir -p "${pkgdir}/var/cache/loolwsd"
+ mkdir -p "${pkgdir}/var/lib/lool/child-roots"
+}
diff --git a/libreoffice-online.install b/libreoffice-online.install
new file mode 100644
index 000000000000..20b7601049ee
--- /dev/null
+++ b/libreoffice-online.install
@@ -0,0 +1,12 @@
+post_install() {
+ getent group lool > /dev/null || groupadd -r lool > /dev/null
+ getent passwd lool > /dev/null || useradd -g lool lool > /dev/null
+ chown -R lool:lool /var/cache/loolwsd \
+ /var/lib/lool/child-roots
+}
+
+post_remove() {
+ userdel -rf lool
+ groupdel lool
+}
+
diff --git a/loolwsd.service b/loolwsd.service
new file mode 100644
index 000000000000..d6a071d35e00
--- /dev/null
+++ b/loolwsd.service
@@ -0,0 +1,12 @@
+[Unit]
+Description=loolwsd as a service
+
+[Service]
+User=lool
+ExecStart=/usr/bin/loolwsd --o:sys_template_path=/var/lib/lool/systemplate --o:lo_template_path=/usr/lib/libreoffice --o:child_root_path=/var/lib/lool/child-roots --o:file_server_root_path=/usr/share/loolwsd
+ExecReload=/bin/kill -HUP $MAINPID
+KillMode=process
+Restart=on-failure
+
+[Install]
+WantedBy=multi-user.target