summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSimon Wilper2017-02-26 10:18:57 +0100
committerSimon Wilper2017-02-26 10:18:57 +0100
commit6e678129e8ebc551a2ad51d982a8f75d1b25efce (patch)
tree332a1666d947eda26f9824fd0c9dde16fc6ce227
downloadaur-6e678129e8ebc551a2ad51d982a8f75d1b25efce.tar.gz
initial commit
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD66
2 files changed, 78 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..82f8172e25f3
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,12 @@
+pkgbase = libreoffice-slim-git
+ pkgdesc = A slimmed down Git version of LibreOffice
+ pkgver = latest
+ pkgrel = 1
+ url = https://www.libreoffice.org/community/developers/
+ arch = x86_64
+ arch = i386
+ license = GPL
+ makedepends = git
+
+pkgname = libreoffice-slim-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..bd4658df3037
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,66 @@
+# Maintainer: Simon Wilper <sxw@chronowerks.de>
+pkgname=libreoffice-slim-git
+pkgver=latest
+pkgrel=1
+pkgdesc="A slimmed down Git version of LibreOffice"
+arch=('x86_64' 'i386')
+url="https://www.libreoffice.org/community/developers/"
+license=('GPL')
+makedepends=('git')
+
+_gitroot=https://anongit.freedesktop.org/git/libreoffice/core.git
+_gitname=core
+
+prepare() {
+ cd "$srcdir"
+ msg "Connecting to GIT server...."
+
+ if [[ -d "$_gitname" ]]; then
+ cd "$_gitname" && git pull -r
+ msg "The local files are updated."
+ else
+ git clone --depth 1 "$_gitroot" "$_gitname"
+ fi
+
+ msg "GIT checkout done or server timeout"
+ msg "Starting build..."
+
+ cd "${srcdir}/${_gitname}"
+
+ [[ -d workdir ]] && make clean
+
+ build_hash=$(git log --pretty=%h | head -n1)
+ build_date=$(date +%Y%m%d)
+ ./autogen.sh\
+ --disable-odk\
+ --enable-epm\
+ --with-package-format=archive\
+ --disable-gtk3\
+ --disable-systray\
+ --disable-cups\
+ --enable-release-build\
+ --enable-python=internal\
+ --with-galleries=no\
+ --with-java=no\
+ --without-fonts\
+ --without-help\
+ --with-vendor="sxw@chronowerks.de"\
+ --with-extra-buildid="This is Sparta: ${build_hash}-${build_date}"\
+ --with-build-version="${pkgver}-${pkgrel}"
+}
+
+build() {
+ cd "${srcdir}/${_gitname}"
+ make build-nocheck
+ cd workdir/installation/LibreOffice/archive/install/en-US
+ msg "Extracting LibreOffice Installation Tarball..."
+ tar xf *.tar.gz
+}
+
+package() {
+ cd "${pkgdir}"
+ install -d -m755 ${pkgdir}/opt/lo
+ cp -r ${srcdir}/${_gitname}/workdir/installation/LibreOffice/archive/install/en-US/LibreOffice*/* ${pkgdir}/opt/lo
+}
+
+# vim:set ts=2 sw=2 tw=0 et: