summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorStefan Husmann2015-06-09 00:34:46 +0200
committerStefan Husmann2015-06-09 00:34:46 +0200
commit84207926bea695db071cd3bf157f48e82de869c6 (patch)
treeacb8b4e3b3cd64ab8950453b7929e92f3706d0d4
downloadaur-84207926bea695db071cd3bf157f48e82de869c6.tar.gz
initial version
-rw-r--r--.SRCINFO23
-rw-r--r--PKGBUILD47
-rw-r--r--fcons.patch31
-rw-r--r--librep.install18
4 files changed, 119 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c35a75ce62c5
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,23 @@
+pkgbase = librep-git
+ pkgdesc = A lisp system for sawfish - git version.
+ pkgver = 0.92.5.2.g9e2355f
+ pkgrel = 1
+ url = http://sawfish.wikia.com
+ install = librep.install
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = git
+ depends = gmp
+ depends = gdbm
+ provides = librep=0.92.5.2.g9e2355f
+ conflicts = librep
+ options = !libtool
+ options = !makeflags
+ source = git://github.com/SawfishWM/librep.git
+ source = fcons.patch
+ sha256sums = SKIP
+ sha256sums = 7279a87c34ad518732889d4ad450f0c7e2b35e6e93239df1ead9fa157e1b1b35
+
+pkgname = librep-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a83c2e598b49
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,47 @@
+# Contibutor: Thomas Dziedzic < gostrc at gmail >
+# Maintainer: Stefan Husmann <stefan-husmann@t-online.de>
+
+pkgname=librep-git
+pkgver=0.92.5.2.g9e2355f
+pkgrel=1
+pkgdesc='A lisp system for sawfish - git version.'
+arch=('i686' 'x86_64')
+url='http://sawfish.wikia.com'
+license=('GPL')
+depends=('gmp' 'gdbm')
+makedepends=('git')
+provides=("librep=$pkgver")
+conflicts=('librep')
+options=('!libtool' '!makeflags')
+install=librep.install
+source=('git://github.com/SawfishWM/librep.git' fcons.patch)
+sha256sums=('SKIP' '7279a87c34ad518732889d4ad450f0c7e2b35e6e93239df1ead9fa157e1b1b35')
+_gitname='librep'
+
+pkgver() {
+ cd "$_gitname"
+ echo $(git describe --always |sed 's/-/./g'|cut -c8-)
+}
+
+prepare() {
+ cd "$_gitname"
+ patch -Np1 < $srcdir/fcons.patch
+}
+
+build() {
+ cd "$_gitname"
+ ./autogen.sh
+ ./configure --disable-static \
+ --prefix=/usr \
+ --libexecdir=/usr/lib/$pkgname \
+ --with-readline \
+ --with-ffi
+ sed -i 's#makeinfo --no-split#makeinfo --force --no-split#' man/Makefile
+ make
+}
+package() {
+ cd $_gitname
+ # create some directories or make install fails
+ install -d $pkgdir/usr/{share/aclocal,lib/pkgconfig}
+ make DESTDIR=$pkgdir install
+}
diff --git a/fcons.patch b/fcons.patch
new file mode 100644
index 000000000000..a3c7c7e06834
--- /dev/null
+++ b/fcons.patch
@@ -0,0 +1,31 @@
+diff -Naur librep_0.92.5.orig/src/repint.h librep_0.92.5.new/src/repint.h
+--- librep_0.92.5.orig/src/repint.h 2015-06-02 22:44:39.565894699 +0200
++++ librep_0.92.5.new/src/repint.h 2015-06-02 22:46:39.865254294 +0200
+@@ -240,27 +240,6 @@
+
+ #include "repint_subrs.h"
+
+-/* If using GCC, make inline_Fcons be Fcons that only takes a procedure
+- call when the heap needs to grow. */
+-
+-#if defined __GNUC__ && defined __OPTIMIZE__
+-extern __inline__ repv inline_Fcons (repv x, repv y);
+-extern __inline__ repv
+-inline_Fcons (repv x, repv y)
+-{
+- rep_cons *c = rep_cons_freelist;
+- if (c == 0)
+- c = rep_allocate_cons ();
+- rep_cons_freelist = rep_CONS (c->cdr);
+- rep_used_cons++;
+- rep_data_after_gc += sizeof(rep_cons);
+-
+- c->car = (x);
+- c->cdr = (y);
+- return rep_CONS_VAL (c);
+-}
+-#else
+ # define inline_Fcons Fcons
+-#endif
+
+ #endif /* REPINT_H */
diff --git a/librep.install b/librep.install
new file mode 100644
index 000000000000..17f4e41bc5c8
--- /dev/null
+++ b/librep.install
@@ -0,0 +1,18 @@
+info_dir=/usr/share/info
+info_files=(librep.info.gz)
+
+post_install() {
+ for f in ${info_files[@]}; do
+ install-info ${info_dir}/$f ${info_dir}/dir 2> /dev/null
+ done
+}
+
+post_upgrade() {
+ post_install $1
+}
+
+pre_remove() {
+ for f in ${info_files[@]}; do
+ install-info --delete ${info_dir}/$f ${info_dir}/dir 2> /dev/null
+ done
+}