summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDanilo Bargen2022-10-03 12:59:35 +0200
committerDanilo Bargen2022-10-03 12:59:44 +0200
commit40d13eacdcb7e3244a78d0a32d7eae15b080d814 (patch)
tree886aa884f5790481fbf09af24b9dfcb239c92794
parent17febf0ee270f26c9bdb323a74905f497b1d515a (diff)
downloadaur-40d13eacdcb7e3244a78d0a32d7eae15b080d814.tar.gz
Unbundle gtest
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD7
2 files changed, 7 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e4dc4e5a7215..bf6e8381f7c3 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = librepcb
pkgdesc = A free EDA software to develop printed circuit boards
pkgver = 0.1.7
- pkgrel = 1
+ pkgrel = 2
url = https://librepcb.org/
arch = x86_64
arch = i686
@@ -10,6 +10,7 @@ pkgbase = librepcb
makedepends = pkg-config
makedepends = qt5-tools
makedepends = fontobene-qt5
+ makedepends = gtest
depends = qt5-svg
depends = hicolor-icon-theme
depends = muparser
diff --git a/PKGBUILD b/PKGBUILD
index 818901f70748..97ca6982496c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -9,7 +9,7 @@
pkgname=librepcb
pkgver=0.1.7
_pkgver=${pkgver/_/-}
-pkgrel=1
+pkgrel=2
pkgdesc="A free EDA software to develop printed circuit boards"
arch=('x86_64' 'i686')
url="https://librepcb.org/"
@@ -26,6 +26,7 @@ makedepends=(
'pkg-config'
'qt5-tools'
'fontobene-qt5'
+ 'gtest'
)
source=(
"https://download.librepcb.org/releases/${_pkgver}/librepcb-${_pkgver}-source.zip"
@@ -49,6 +50,7 @@ build() {
rm -rf libs/muparser/
rm -rf libs/polyclipping/
rm -rf libs/quazip/
+ rm -rf libs/googletest/
# Remove bundled hoedown, it is not needed on Qt >=5.14
rm -rf libs/hoedown/
@@ -62,7 +64,8 @@ build() {
-DUNBUNDLE_FONTOBENE_QT5=1 \
-DUNBUNDLE_MUPARSER=1 \
-DUNBUNDLE_POLYCLIPPING=1 \
- -DUNBUNDLE_QUAZIP=1
+ -DUNBUNDLE_QUAZIP=1 \
+ -DUNBUNDLE_GTEST=1
make
}