diff options
author | Danilo Bargen | 2021-11-04 22:51:46 +0100 |
---|---|---|
committer | Danilo Bargen | 2021-11-04 22:51:46 +0100 |
commit | 5fce23c92dd593558bcfbcf79bb67540a612d062 (patch) | |
tree | 7a98aae0720eb98df401c78d2f23cd60b998ec05 | |
parent | 280970ea89d15be2a4902e7fbf58e91d771e1c23 (diff) | |
download | aur-5fce23c92dd593558bcfbcf79bb67540a612d062.tar.gz |
LibrePCB 0.1.6: Migrate to CMake
-rw-r--r-- | PKGBUILD | 29 |
1 files changed, 13 insertions, 16 deletions
@@ -7,23 +7,27 @@ # See https://wiki.archlinux.org/index.php/Makepkg#Signature_checking # for more details # on package signing. pkgname=librepcb -pkgver=0.1.5 +pkgver=0.1.6 _pkgver=${pkgver/_/-} -pkgrel=3 +pkgrel=1 pkgdesc="A free EDA software to develop printed circuit boards" arch=('x86_64' 'i686') url="http://librepcb.org/" license=('GPL') depends=( - 'desktop-file-utils' 'hicolor-icon-theme' 'qt5-base' 'qt5-svg' + 'hicolor-icon-theme' + 'qt5-svg' +) +makedepends=( + 'cmake' + 'qt5-tools' ) -makedepends=('qt5-tools') source=( "https://download.librepcb.org/releases/${_pkgver}/librepcb-${_pkgver}-source.zip" "https://download.librepcb.org/releases/${_pkgver}/librepcb-${_pkgver}-source.zip.asc" ) sha256sums=( - 'f956dfa5b9ad1faffcab7f5dd03f158c2b97a7c82cfc9a09dc4066cbcf0db76a' + '8c7bf475ed59eb5b5e4b13073b96b9468ee01fb6980ef2b3471b1fbb39c46721' 'SKIP' ) validpgpkeys=('D6F9AF572228C5BCD6B538407EF3061F5C8D5E25') @@ -31,23 +35,16 @@ validpgpkeys=('D6F9AF572228C5BCD6B538407EF3061F5C8D5E25') build() { cd "${srcdir}/librepcb-${_pkgver}/" mkdir -p build && cd build - qmake -r ../librepcb.pro \ - PREFIX="${pkgdir}/usr" \ - CONFIG+=release + cmake .. \ + -DCMAKE_BUILD_TYPE=Release \ + -DCMAKE_INSTALL_PREFIX="${pkgdir}/usr" \ + -DLIBREPCB_SHARE=/usr/share/librepcb make } package() { cd "${srcdir}/librepcb-${_pkgver}/build/" make install - - # Clean up: https://github.com/LibrePCB/LibrePCB/issues/778 - rm -rf "${pkgdir}/usr/include/fontobene-qt5/" - - # Install development utils - install -s -m 755 \ - "${srcdir}/librepcb-${_pkgver}/build/output/uuid-generator" \ - "${pkgdir}/usr/bin/librepcb-uuid-generator" } # vim:set ts=2 sw=2 et: |