summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDanilo Bargen2018-11-08 22:23:59 +0100
committerDanilo Bargen2018-11-08 22:23:59 +0100
commitaa657d9bbabfc490845b451083b346c1fba1e427 (patch)
tree112f4c34b4abfc500a7881888b94a0becb16c425
parentde7bbbb0e8dd982b62cdad9070f9f2ca17f3a7cc (diff)
downloadaur-aa657d9bbabfc490845b451083b346c1fba1e427.tar.gz
Version 0.1.0_rc2-2 (add PGP)
-rw-r--r--.SRCINFO6
-rw-r--r--.gitignore1
-rw-r--r--PKGBUILD14
3 files changed, 16 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7c52a99f84b3..2e5802f773cd 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
# Generated by mksrcinfo v8
-# Sun Nov 4 20:52:57 UTC 2018
+# Thu Nov 8 21:23:31 UTC 2018
pkgbase = librepcb-appimage
pkgdesc = A free EDA software to develop printed circuit boards (binary AppImage version).
pkgver = 0.1.0_rc2
- pkgrel = 1
+ pkgrel = 2
url = http://librepcb.org/
arch = x86_64
license = GPL
@@ -16,7 +16,9 @@ pkgbase = librepcb-appimage
options = !strip
options = !emptydirs
source = https://download.librepcb.org/releases/0.1.0-rc2/librepcb-0.1.0-rc2-linux-x86_64.AppImage
+ source = https://download.librepcb.org/releases/0.1.0-rc2/librepcb-0.1.0-rc2-linux-x86_64.AppImage.asc
sha256sums = ee21d7defc78737d430d43b8848131e8c618822623355958285aaa74d964c8a5
+ sha256sums = SKIP
pkgname = librepcb-appimage
diff --git a/.gitignore b/.gitignore
index e3ac5ec0a65f..ac762af8bf07 100644
--- a/.gitignore
+++ b/.gitignore
@@ -3,3 +3,4 @@ src/
*.swp
*.tar.xz
*.AppImage
+*.asc
diff --git a/PKGBUILD b/PKGBUILD
index 851d09080278..2cddb9f424e2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,9 @@
# Maintainer: Danilo Bargen <aur at dbrgn dot ch>
+# PGP key is on keyservers
pkgname=librepcb-appimage
pkgver=0.1.0_rc2
_pkgver=${pkgver/_/-}
-pkgrel=1
+pkgrel=2
pkgdesc="A free EDA software to develop printed circuit boards (binary AppImage version)."
arch=('x86_64')
url="http://librepcb.org/"
@@ -13,8 +14,15 @@ conflicts=('librepcb')
_appimage="librepcb-${_pkgver}-linux-${arch}.AppImage"
noextract=("${_appimage}")
options=('!strip' '!emptydirs')
-source=("https://download.librepcb.org/releases/${_pkgver}/${_appimage}")
-sha256sums=('ee21d7defc78737d430d43b8848131e8c618822623355958285aaa74d964c8a5')
+source=(
+ "https://download.librepcb.org/releases/${_pkgver}/${_appimage}"
+ "https://download.librepcb.org/releases/${_pkgver}/${_appimage}.asc"
+)
+sha256sums=(
+ 'ee21d7defc78737d430d43b8848131e8c618822623355958285aaa74d964c8a5'
+ 'SKIP'
+)
+validpgpkeys=('D6F9AF572228C5BCD6B538407EF3061F5C8D5E25')
build() {
chmod +x ${_appimage}