summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDanilo Bargen2015-10-20 08:35:37 +0200
committerDanilo Bargen2015-10-20 08:38:11 +0200
commit26a4e292be70d1c039a5e537ac0dbe8e58b95626 (patch)
tree07824297380e032f28ffceb15094305599b3d6ea
downloadaur-26a4e292be70d1c039a5e537ac0dbe8e58b95626.tar.gz
Initial version
-rw-r--r--.MTREEbin0 -> 187 bytes
-rw-r--r--.PKGINFO27
-rw-r--r--.SRCINFO20
-rw-r--r--.gitignore5
-rw-r--r--PKGBUILD42
5 files changed, 94 insertions, 0 deletions
diff --git a/.MTREE b/.MTREE
new file mode 100644
index 000000000000..a6c1b996a0d2
--- /dev/null
+++ b/.MTREE
Binary files differ
diff --git a/.PKGINFO b/.PKGINFO
new file mode 100644
index 000000000000..baad6dbf80e4
--- /dev/null
+++ b/.PKGINFO
@@ -0,0 +1,27 @@
+# Generated by makepkg 4.2.1
+# using fakeroot version 1.20.2
+# Sun Oct 11 17:00:15 UTC 2015
+pkgname = librepcb-git
+pkgver = -1
+pkgdesc = LibrePCB is a free EDA software to develop printed circuit boards.
+url = http://librepcb.org/
+builddate = 1444582815
+packager = Unknown Packager
+size = 4096
+arch = x86_64
+license = GPL
+conflict = librepcb
+provides = librepcb
+depend = qt5-base
+depend = glu
+makedepend = git
+makedepend = qconf
+makepkgopt = strip
+makepkgopt = docs
+makepkgopt = !libtool
+makepkgopt = !staticlibs
+makepkgopt = emptydirs
+makepkgopt = zipman
+makepkgopt = purge
+makepkgopt = !upx
+makepkgopt = !debug
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c7fd246a777d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = librepcb-git
+ pkgdesc = LibrePCB is a free EDA software to develop printed circuit boards.
+ pkgver = r549.95b8d1a
+ pkgrel = 1
+ url = http://librepcb.org/
+ arch = x86_64
+ arch = i686
+ license = GPL
+ makedepends = git
+ makedepends = qconf
+ depends = qt5-base
+ depends = qt5-webkit
+ depends = glu
+ provides = librepcb
+ conflicts = librepcb
+ source = git+https://github.com/LibrePCB/LibrePCB
+ md5sums = SKIP
+
+pkgname = librepcb-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..d6457d92b357
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,5 @@
+pkg/
+src/
+*.swp
+*.tar.xz
+LibrePCB/
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..bfb8332cddd5
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,42 @@
+# Maintainer: Danilo Bargen <aur at dbrgn dot ch>
+pkgname=librepcb-git
+_fullname=LibrePCB
+pkgver=r549.95b8d1a
+pkgrel=1
+pkgdesc="LibrePCB is a free EDA software to develop printed circuit boards."
+arch=('x86_64' 'i686')
+url="http://librepcb.org/"
+license=('GPL')
+depends=('qt5-base' 'qt5-webkit' 'glu')
+makedepends=('git' 'qconf')
+provides=('librepcb')
+conflicts=('librepcb')
+source=('git+https://github.com/LibrePCB/LibrePCB')
+md5sums=('SKIP')
+
+build() {
+ # Temporary build dir
+ rm -rf "$srcdir/$_fullname-build"
+ git clone "$srcdir/$_fullname" "$srcdir/$_fullname-build"
+ cd "$srcdir/$_fullname-build"
+
+ # Prepare
+ cd "$srcdir/$_fullname-build"
+ mkdir build && cd build
+ qmake -r ../librepcb.pro PREFIX=${pkgdir}/usr
+
+ # Compile
+ make
+}
+
+package() {
+ cd "$srcdir/$_fullname-build/build"
+ make install
+}
+
+pkgver() {
+ cd "$srcdir/$_fullname"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+# vim:set ts=2 sw=2 et: