summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKuldeep Singh Dhaka2016-12-19 13:13:00 +0530
committerKuldeep Singh Dhaka2016-12-20 01:26:35 +0530
commit1e14db821903329d9a716f13279bae2d487a75c2 (patch)
tree5cc2ba4f8d2873d2389ca106168c8f52406e617e
downloadaur-1e14db821903329d9a716f13279bae2d487a75c2.tar.gz
Inital commit
-rw-r--r--.SRCINFO25
-rw-r--r--PKGBUILD45
2 files changed, 70 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..315d7e752a1b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,25 @@
+# Generated by mksrcinfo v8
+# Mon Dec 19 19:55:08 UTC 2016
+pkgbase = libreplot-git
+ pkgdesc = Data Visualizing using GPU via OpenGL3+ (or GLES2+), written in C
+ pkgver = 33.2563af7
+ pkgrel = 1
+ url = https://www.madresistor.org/box0
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = cmake
+ makedepends = git
+ depends = libepoxy
+ depends = fontconfig
+ depends = freetype2
+ depends = harfbuzz
+ depends = libpng
+ provides = libreplot
+ conflicts = libreplot
+ replaces = libreplot
+ source = git+https://gitlab.com/madresistor/libreplot.git
+ md5sums = SKIP
+
+pkgname = libreplot-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8598b4db10b9
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,45 @@
+# Maintainer: Kuldeep Singh Dhaka <kuldeepdhaka9@gmail.com>
+
+pkgname=libreplot-git
+_pkgname=libreplot
+pkgver=33.2563af7
+pkgrel=1
+pkgdesc="Data Visualizing using GPU via OpenGL3+ (or GLES2+), written in C"
+arch=('i686' 'x86_64')
+url="https://www.madresistor.org/box0"
+license=('GPL')
+provides=(libreplot)
+conflicts=(libreplot)
+replaces=(libreplot)
+source=("git+https://gitlab.com/madresistor/$_pkgname.git")
+# TODO: Find a way in which we can tell that
+# we need atleast one of ('libepoxy''libgl' 'libgles').
+# libepoxy being the most preffered and libgles the least
+depends=('libepoxy' 'fontconfig' 'freetype2' 'harfbuzz' 'libpng')
+makedepends=('cmake' 'git')
+md5sums=('SKIP')
+
+
+pkgver() {
+ cd "$srcdir/$_pkgname"
+ echo "$(git rev-list --count HEAD).$(git describe --always )"
+}
+
+prepare() {
+ cd "$srcdir/$_pkgname"
+ if [[ -d build ]]; then
+ rm -rf build
+ fi
+ mkdir build
+}
+
+build() {
+ cd "$srcdir/$_pkgname/build"
+ # We are not building demo examples as they will not be installed
+ cmake -DCMAKE_INSTALL_PREFIX='/usr' -DBUILD_DEMO=NO -DBUILD_SHARED_LIBS='TRUE' ..
+ make
+}
+
+package() {
+ make -C "$srcdir/$_pkgname/build" DESTDIR="${pkgdir}" install
+}