summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorlarchunix2019-07-04 16:03:26 +0200
committerlarchunix2019-07-04 16:03:26 +0200
commit81bd23ed359a508854d06d842e499c152198f90c (patch)
tree356003553a15068d393b2457af1d826e117ddc3c
parente77ec668949b1e41ff732dea30706ad44ef83b22 (diff)
downloadaur-81bd23ed359a508854d06d842e499c152198f90c.tar.gz
Update to upstream release 1.10.4
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD10
2 files changed, 7 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9db6aff8a62b..db99a3bff514 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = librepo
pkgdesc = Repodata downloading library
- pkgver = 1.10.3
+ pkgver = 1.10.4
pkgrel = 1
url = https://github.com/rpm-software-management/librepo
arch = i686
@@ -21,8 +21,8 @@ pkgbase = librepo
depends = openssl
depends = zchunk>=0.9.11
optdepends = python: for python bindings
- source = https://github.com/rpm-software-management/librepo/archive/1.10.3/librepo-1.10.3.tar.gz
- md5sums = c5b959a9142c75956648968762d953d0
+ source = https://github.com/rpm-software-management/librepo/archive/1.10.4/librepo-1.10.4.tar.gz
+ md5sums = f0e872d01ec293ee45f84ae4fd4d5d9c
pkgname = librepo
diff --git a/PKGBUILD b/PKGBUILD
index 56c3384b4a4f..14d499217fbe 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,5 +1,5 @@
pkgname=librepo
-pkgver=1.10.3
+pkgver=1.10.4
pkgrel=1
pkgdesc="Repodata downloading library"
arch=('i686' 'x86_64')
@@ -11,7 +11,7 @@ checkdepends=('check' 'python-flask' 'python-gpgme' 'python-nose'
'python-pyxattr' 'python-requests')
optdepends=('python: for python bindings')
source=("$url/archive/$pkgver/$pkgname-$pkgver.tar.gz")
-md5sums=('c5b959a9142c75956648968762d953d0')
+md5sums=('f0e872d01ec293ee45f84ae4fd4d5d9c')
prepare() {
cd "$pkgname-$pkgver"
@@ -25,6 +25,7 @@ build() {
cmake -DCMAKE_BUILD_TYPE=Release \
-DCMAKE_C_FLAGS="$CFLAGS $CPPFLAGS" \
-DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_INSTALL_LIBDIR=lib \
-DPYTHON_DESIRED=3 \
-DENABLE_DOCS=OFF \
-DENABLE_PYTHON_TESTS=ON \
@@ -41,11 +42,8 @@ check() {
package() {
cd "$pkgname-$pkgver"/build
+
make DESTDIR="$pkgdir/" install
- if [[ "$CARCH" == "x86_64" ]]; then
- mv "$pkgdir/"usr/lib64/* "$pkgdir/"usr/lib
- rmdir "$pkgdir/"usr/lib64
- fi
install -Dp -m644 ../README.md "$pkgdir/usr/share/doc/$pkgname/README.md"
}