summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorlarchunix2015-09-22 19:20:31 +0200
committerlarchunix2015-09-22 19:21:46 +0200
commitc421148c2a7e3dfd08cca8884d35da3b14a5ae87 (patch)
tree6b7d3124a5dc37c2d5ceb27f0c532ca250e50cfb
parent6987bbc3adb68f070141a7f8d52ef080f83a472b (diff)
downloadaur-c421148c2a7e3dfd08cca8884d35da3b14a5ae87.tar.gz
Update upstream URL and use proper tag for version 1.7.6
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD20
2 files changed, 15 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e7997caaa675..b64676d04d55 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -2,7 +2,7 @@ pkgbase = librepo
pkgdesc = Repodata downloading library
pkgver = 1.7.16
pkgrel = 2
- url = https://github.com/Tojaj/librepo
+ url = https://github.com/rpm-software-management/librepo
arch = i686
arch = x86_64
license = LGPL2.1
@@ -18,9 +18,9 @@ pkgbase = librepo
depends = glib2
depends = gpgme
optdepends = python: for python bindings
- source = librepo-1.7.16.tar.gz::https://github.com/Tojaj/librepo/archive/d9bed0d9f96b505fb86a1adc50b3d6f8275fab93.tar.gz
- source = xattr-skiptest.patch::https://github.com/rholy/librepo/commit/96457dc6a76418af0ea4f8c3405471710fd06b9d.patch
- md5sums = 3df89269456df9dce6d1205b8a717f53
+ source = https://github.com/rpm-software-management/librepo/archive/librepo-1.7.16.tar.gz
+ source = xattr-skiptest.patch::https://github.com/rpm-software-management/librepo/commit/96457dc6a76418af0ea4f8c3405471710fd06b9d.patch
+ md5sums = d09540e71574ee8b1b6ea97aa0a61b89
md5sums = 60b12b69a8d5e16f32d79a4f5bf02fa4
pkgname = librepo
diff --git a/PKGBUILD b/PKGBUILD
index cd1c11c3e966..47faa61f31a7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,30 +1,32 @@
pkgname=librepo
-_gitrev=d9bed0d9f96b505fb86a1adc50b3d6f8275fab93
pkgver=1.7.16
pkgrel=2
pkgdesc="Repodata downloading library"
arch=('i686' 'x86_64')
-url="https://github.com/Tojaj/$pkgname"
+url="https://github.com/rpm-software-management/$pkgname"
license=('LGPL2.1')
depends=('curl' 'expat' 'glib2' 'gpgme')
makedepends=('cmake' 'python')
checkdepends=('check' 'python-flask' 'python-nose' 'python-pygpgme' 'python-pyxattr')
optdepends=('python: for python bindings')
-source=("$pkgname-$pkgver.tar.gz::$url/archive/$_gitrev.tar.gz"
- "xattr-skiptest.patch::https://github.com/rholy/$pkgname/commit/96457dc6a76418af0ea4f8c3405471710fd06b9d.patch")
-md5sums=('3df89269456df9dce6d1205b8a717f53'
+source=("$url/archive/$pkgname-$pkgver.tar.gz"
+ "xattr-skiptest.patch::$url/commit/96457dc6a76418af0ea4f8c3405471710fd06b9d.patch")
+md5sums=('d09540e71574ee8b1b6ea97aa0a61b89'
'60b12b69a8d5e16f32d79a4f5bf02fa4')
prepare() {
- cd "$pkgname-$_gitrev"
+ mv "$pkgname-$pkgname-$pkgver" "$pkgname-$pkgver"
+
+ cd "$pkgname-$pkgver"
rm -rf build
mkdir build
+ # FTBFS with filesystems which do not have xattr support
patch -p1 < "$srcdir"/xattr-skiptest.patch
}
build() {
- cd "$pkgname-$_gitrev"/build
+ cd "$pkgname-$pkgver"/build
cmake -DCMAKE_BUILD_TYPE=Release \
-DCMAKE_INSTALL_PREFIX=/usr \
-DPYTHON_DESIRED=3 \
@@ -34,12 +36,12 @@ build() {
}
check() {
- cd "$pkgname-$_gitrev"/build
+ cd "$pkgname-$pkgver"/build
make ARGS="-V" test
}
package() {
- cd "$pkgname-$_gitrev"/build
+ cd "$pkgname-$pkgver"/build
make DESTDIR="$pkgdir/" install
if [[ "$CARCH" == "x86_64" ]]; then
mv "$pkgdir/"usr/lib64/* "$pkgdir/"usr/lib