summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMaddie Zhan2020-03-09 15:26:10 +0800
committerMaddie Zhan2020-03-09 15:26:10 +0800
commit9ed3cc370701e9920832197271d3f26913a771bc (patch)
treed09b9c26bc5468d83c3c000249923281c0fc66df
downloadaur-9ed3cc370701e9920832197271d3f26913a771bc.tar.gz
v1.0.0
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD22
2 files changed, 42 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..764e0df996d2
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = librespeed-cli-bin
+ pkgdesc = Command line interface for LibreSpeed speed test backends
+ pkgver = 1.0.0
+ pkgrel = 1
+ url = https://github.com/librespeed/speedtest-cli
+ arch = x86_64
+ arch = aarch64
+ arch = armv7h
+ license = LGPL3
+ provides = librespeed-cli
+ conflicts = librespeed-cli
+ source_x86_64 = https://github.com/librespeed/speedtest-cli/releases/download/v1.0.0/librespeed-cli-linux-amd64.tar.gz
+ sha256sums_x86_64 = 573983a5a565a6f06739c78a7e5b8b953a0ef391ba56824f5e69a6044195aaf9
+ source_aarch64 = https://github.com/librespeed/speedtest-cli/releases/download/v1.0.0/librespeed-cli-linux-arm64.tar.gz
+ sha256sums_aarch64 = 805b74ad4ea88c2df21f111e53bce9dd6f67e4e4807488af2cbe2e59ba6a7a13
+ source_armv7h = https://github.com/librespeed/speedtest-cli/releases/download/v1.0.0/librespeed-cli-linux-armv7.tar.gz
+ sha256sums_armv7h = eb13996627f904cc795f7bcf1f55d0a4f631c5118bb210a09c5bb2bdb201b4df
+
+pkgname = librespeed-cli-bin
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..73446dc3a108
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,22 @@
+# Maintainer: Maddie Zhan <maddie at zzz dot cat>
+pkgname=librespeed-cli-bin
+pkgver=1.0.0
+pkgrel=1
+pkgdesc="Command line interface for LibreSpeed speed test backends"
+arch=('x86_64' 'aarch64' 'armv7h')
+url="https://github.com/librespeed/speedtest-cli"
+license=('LGPL3')
+provides=('librespeed-cli')
+conflicts=('librespeed-cli')
+
+source_x86_64=("https://github.com/librespeed/speedtest-cli/releases/download/v${pkgver}/${pkgname/-bin/}-linux-amd64.tar.gz")
+source_aarch64=("https://github.com/librespeed/speedtest-cli/releases/download/v${pkgver}/${pkgname/-bin/}-linux-arm64.tar.gz")
+source_armv7h=("https://github.com/librespeed/speedtest-cli/releases/download/v${pkgver}/${pkgname/-bin/}-linux-armv7.tar.gz")
+
+sha256sums_x86_64=('573983a5a565a6f06739c78a7e5b8b953a0ef391ba56824f5e69a6044195aaf9')
+sha256sums_aarch64=('805b74ad4ea88c2df21f111e53bce9dd6f67e4e4807488af2cbe2e59ba6a7a13')
+sha256sums_armv7h=('eb13996627f904cc795f7bcf1f55d0a4f631c5118bb210a09c5bb2bdb201b4df')
+
+package() {
+ install -Dm755 "${srcdir}/${pkgname/-bin}" "${pkgdir}/usr/bin/${pkgname/-bin}"
+}