summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDeathSec2017-03-22 22:39:55 +0530
committerDeathSec2017-03-22 22:39:55 +0530
commit7641dc78cc9e991c366c0d74923155c5252a9cd6 (patch)
treea18c441f5d5b03e377d3ee36d5ab7efc1d76fb62
downloadaur-7641dc78cc9e991c366c0d74923155c5252a9cd6.tar.gz
adding libresponse release v0.0.1
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD22
2 files changed, 37 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..5eadfdb787d8
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = libresponse
+ pkgdesc = A Easy to use HTTP , HTTPS , FTP , SCP , SFTP Library for C/C++
+ pkgver = 0.0.1
+ pkgrel = 1
+ url = https://github.com/DeathSec/response
+ arch = i686
+ arch = x86_64
+ license = apache
+ depends = curl
+ depends = cmake
+ source = https://github.com/deathsec/response/archive/v0.0.1.tar.gz
+ sha256sums = 945ec206f354f7c3208b7055ac53670d1b282ae926d04259c9454cc274adb9f3
+
+pkgname = libresponse
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c768e7d18956
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,22 @@
+# Maintainer: DeathSec
+pkgname=libresponse
+pkgver=0.0.1
+pkgrel=1
+pkgdesc="A Easy to use HTTP , HTTPS , FTP , SCP , SFTP Library for C/C++"
+arch=('i686' 'x86_64')
+url="https://github.com/DeathSec/response"
+license=('apache')
+depends=('curl' 'cmake')
+source=(https://github.com/deathsec/response/archive/v$pkgver.tar.gz)
+sha256sums=('945ec206f354f7c3208b7055ac53670d1b282ae926d04259c9454cc274adb9f3')
+
+build() {
+ cd "response-$pkgver"
+ cmake .
+ make
+}
+
+package() {
+ cd "response-$pkgver"
+ make DESTDIR="$pkgdir/" install
+}