summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorxiota2024-11-06 23:56:54 +0000
committerxiota2024-11-06 23:57:40 +0000
commitf721507e8b95855afbe6274c505cb79fab25bd63 (patch)
tree380024e194bdc5cfc61809d68b226b1e2651f665
parentacb321c10b8c11b9fb2f7eb9c863123c9868ef18 (diff)
downloadaur-f721507e8b95855afbe6274c505cb79fab25bd63.tar.gz
1.1.r59
-rw-r--r--.SRCINFO19
-rw-r--r--.gitignore4
-rw-r--r--.nvchecker.toml4
-rw-r--r--PKGBUILD35
4 files changed, 36 insertions, 26 deletions
diff --git a/.SRCINFO b/.SRCINFO
index bbf138623281..c0532e3bcf70 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = libresprite-git
pkgdesc = Animated sprite editor and pixel art tool
- pkgver = 1.0.r245.gc99d366
+ pkgver = 1.1.r59.ga678ddf
pkgrel = 1
url = https://github.com/LibreSprite/LibreSprite
arch = x86_64
@@ -9,13 +9,16 @@ pkgbase = libresprite-git
makedepends = cmake
makedepends = git
makedepends = gtest
+ makedepends = ninja
depends = curl
depends = freetype2
depends = giflib
+ depends = libarchive
depends = libjpeg-turbo
depends = libpng
depends = libwebp
- depends = lua
+ depends = libxcb
+ depends = libxi
depends = pixman
depends = sdl2
depends = sdl2_image
@@ -25,13 +28,11 @@ pkgbase = libresprite-git
conflicts = aseprite
conflicts = libresprite
source = libresprite::git+https://github.com/LibreSprite/LibreSprite.git
- source = clip::git+https://github.com/aseprite/clip.git
- source = duktape::git+https://github.com/libresprite/duktape.git
- source = flic::git+https://github.com/aseprite/flic.git
- source = observable::git+https://github.com/dacap/observable.git
- source = simpleini::git+https://github.com/aseprite/simpleini.git
- source = undo::git+https://github.com/aseprite/undo.git
- sha256sums = SKIP
+ source = aseprite.clip::git+https://github.com/aseprite/clip.git
+ source = aseprite.flic::git+https://github.com/aseprite/flic.git
+ source = aseprite.simpleini::git+https://github.com/aseprite/simpleini.git
+ source = aseprite.undo::git+https://github.com/aseprite/undo.git
+ source = libresprite.duktape::git+https://github.com/libresprite/duktape.git
sha256sums = SKIP
sha256sums = SKIP
sha256sums = SKIP
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..018a3de08144
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*
+!PKGBUILD
+!.SRCINFO
+!.gitignore
diff --git a/.nvchecker.toml b/.nvchecker.toml
new file mode 100644
index 000000000000..35ba247a391b
--- /dev/null
+++ b/.nvchecker.toml
@@ -0,0 +1,4 @@
+[libresprite-git]
+source = "git"
+git = "https://github.com/LibreSprite/LibreSprite.git"
+prefix = "v"
diff --git a/PKGBUILD b/PKGBUILD
index 6a108019cdc6..710ad253e559 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
_pkgname="libresprite"
pkgname="$_pkgname-git"
-pkgver=1.0.r245.gc99d366
+pkgver=1.1.r59.ga678ddf
pkgrel=1
pkgdesc="Animated sprite editor and pixel art tool"
url='https://github.com/LibreSprite/LibreSprite'
@@ -14,10 +14,12 @@ depends=(
'curl'
'freetype2'
'giflib'
+ 'libarchive'
'libjpeg-turbo'
'libpng'
'libwebp'
- 'lua'
+ 'libxcb'
+ 'libxi'
'pixman'
'sdl2'
'sdl2_image'
@@ -28,6 +30,7 @@ makedepends=(
'cmake'
'git'
'gtest'
+ 'ninja'
)
provides=(
@@ -42,12 +45,11 @@ _pkgsrc="$_pkgname"
source=(
"$_pkgsrc"::"git+https://github.com/LibreSprite/LibreSprite.git"
- 'clip'::'git+https://github.com/aseprite/clip.git'
- 'duktape'::'git+https://github.com/libresprite/duktape.git'
- 'flic'::'git+https://github.com/aseprite/flic.git'
- 'observable'::'git+https://github.com/dacap/observable.git'
- 'simpleini'::'git+https://github.com/aseprite/simpleini.git'
- 'undo'::'git+https://github.com/aseprite/undo.git'
+ 'aseprite.clip'::'git+https://github.com/aseprite/clip.git'
+ 'aseprite.flic'::'git+https://github.com/aseprite/flic.git'
+ 'aseprite.simpleini'::'git+https://github.com/aseprite/simpleini.git'
+ 'aseprite.undo'::'git+https://github.com/aseprite/undo.git'
+ 'libresprite.duktape'::'git+https://github.com/libresprite/duktape.git'
)
sha256sums=(
@@ -58,7 +60,6 @@ sha256sums=(
'SKIP'
'SKIP'
'SKIP'
- 'SKIP'
)
pkgver() {
@@ -70,12 +71,11 @@ pkgver() {
prepare() {
cd "$_pkgsrc"
local _submodules=(
- 'clip'::'src/clip'
- 'duktape'::'third_party/duktape'
- 'flic'::'src/flic'
- 'observable'::'src/observable'
- 'simpleini'::'third_party/simpleini'
- 'undo'::'src/undo'
+ 'aseprite.clip'::'src/clip'
+ 'aseprite.flic'::'src/flic'
+ 'aseprite.simpleini'::'third_party/simpleini'
+ 'aseprite.undo'::'src/undo'
+ 'libresprite.duktape'::'third_party/duktape'
)
local _module
for _module in "${_submodules[@]}"; do
@@ -89,8 +89,9 @@ build() {
local _cmake_options=(
-B build
-S "$_pkgsrc"
-
- -DCMAKE_INSTALL_PREFIX="/usr"
+ -G Ninja
+ -DCMAKE_BUILD_TYPE=None
+ -DCMAKE_INSTALL_PREFIX='/usr'
-Wno-dev
)