summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoralive4ever2016-06-18 18:57:14 +0700
committeralive4ever2016-06-18 18:57:14 +0700
commit9fc353a7725ac84b762aae53b913ca9dfbc63e4a (patch)
tree440269722e666a6fad96e48714a04903f9d26029
parent61497602f545ae3f7dda70d236b0b7bf300362f1 (diff)
downloadaur-9fc353a7725ac84b762aae53b913ca9dfbc63e4a.tar.gz
Enabling static build
To avoid library and filename conflict, I've disabled shared and static library. This should make nc binary a little bigger, but it's okay.
-rw-r--r--PKGBUILD14
1 files changed, 6 insertions, 8 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 8f35a31165f9..4e13166b6938 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -9,31 +9,29 @@ license=('bsd' 'custom:Openssl')
depends=('glibc' 'ca-certificates')
provides=('netcat')
conflicts=('openbsd-netcat' 'gnu-netcat')
-source=("http://ftp.openbsd.org/pub/OpenBSD/LibreSSL/libressl-${pkgver}.tar.gz" "http://ftp.openbsd.org/pub/OpenBSD/LibreSSL/libressl-${pkgver}.tar.gz.asc")
+source=("http://ftp.openbsd.org/pub/OpenBSD/LibreSSL/libressl-${pkgver}.tar.gz"
+ "http://ftp.openbsd.org/pub/OpenBSD/LibreSSL/libressl-${pkgver}.tar.gz.asc")
sha256sums=('121922b13169cd47a85e3e77f0bc129f8d04247193b42491cb1fab9074e80477'
'SKIP')
validpgpkeys=('A1EB079B8D3EB92B4EBD3139663AF51BD5E4D8D5') # Brent Cook <bcook@openbsd.org>
build() {
cd $srcdir/libressl-${pkgver}/
-./configure --prefix=/usr --sysconfdir=/etc --localstatedir=/var --enable-nc --enable-static --with-pic=yes
+./configure --prefix=/usr --sysconfdir=/etc --localstatedir=/var --enable-nc --disable-static \
+ --disable-shared --with-pic=yes
make
}
check() {
cd $srcdir/libressl-${pkgver}/
-make check
+make -k check
}
package() {
cd $srcdir/libressl-${pkgver}
mkdir -p $pkgdir/usr/bin
-install -m 755 ./apps/nc/.libs/nc $pkgdir/usr/bin/nc
+install -m 755 ./apps/nc/nc $pkgdir/usr/bin/nc
ln -s nc $pkgdir/usr/bin/netcat
-mkdir -p $pkgdir/usr/lib
-install -m 644 ./tls/.libs/libtls.so.11 $pkgdir/usr/lib/libtls.so.11
-install -m 644 ./crypto/.libs/libcrypto.so.38 $pkgdir/usr/lib/libcrypto.so.38
-install -m 644 ./ssl/.libs/libssl.so.39 $pkgdir/usr/lib/libssl.so.39
mkdir -p $pkgdir/usr/share/man/man1
install -m 644 ./apps/nc/nc.1 $pkgdir/usr/share/man/man1/nc.1
mkdir -p $pkgdir/usr/share/licenses/$pkgname