summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoralive4ever2016-06-18 01:33:20 +0700
committeralive4ever2016-06-18 01:33:20 +0700
commitaa2d163ce725d4ae410dfcc940d086ead90b2ca5 (patch)
treed712c9a82cbff3d706e76bf73787dcd28c940bc4
downloadaur-aa2d163ce725d4ae410dfcc940d086ead90b2ca5.tar.gz
First commit
LibreSSL provides nc tool with support for TLS protocol using -c switch. This is an enhancement over traditional openbsd-netcat. Note that nc here depends on libtls.so.11 and libcrypto.so.38 from libressl. If you have installed libressl from aur, file conflict may occur. Beware!
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD33
2 files changed, 55 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..bd64284432b4
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+pkgbase = libressl-netcat
+ pkgdesc = Low level UDP/TCP connection tool with support for TLS protocol
+ pkgver = 2.4.1
+ pkgrel = 1
+ url = http://www.libressl.org
+ arch = x86_64
+ arch = i386
+ license = bsd
+ license = custom:Openssl
+ depends = glibc
+ depends = ca-certificates
+ provides = netcat
+ conflicts = openbsd-netcat
+ conflicts = gnu-netcat
+ source = http://ftp.openbsd.org/pub/OpenBSD/LibreSSL/libressl-2.4.1.tar.gz
+ source = http://ftp.openbsd.org/pub/OpenBSD/LibreSSL/libressl-2.4.1.tar.gz.asc
+ validpgpkeys = A1EB079B8D3EB92B4EBD3139663AF51BD5E4D8D5
+ sha256sums = 121922b13169cd47a85e3e77f0bc129f8d04247193b42491cb1fab9074e80477
+ sha256sums = SKIP
+
+pkgname = libressl-netcat
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9da0a1ae6f60
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer=alive4ever
+pkgname=libressl-netcat
+pkgver=2.4.1
+pkgrel=1
+arch=('x86_64' 'i386')
+pkgdesc="Low level UDP/TCP connection tool with support for TLS protocol"
+url=http://www.libressl.org
+license=('bsd' 'custom:Openssl')
+depends=('glibc' 'ca-certificates')
+provides=('netcat')
+conflicts=('openbsd-netcat' 'gnu-netcat')
+source=("http://ftp.openbsd.org/pub/OpenBSD/LibreSSL/libressl-${pkgver}.tar.gz" "http://ftp.openbsd.org/pub/OpenBSD/LibreSSL/libressl-${pkgver}.tar.gz.asc")
+sha256sums=('121922b13169cd47a85e3e77f0bc129f8d04247193b42491cb1fab9074e80477'
+ 'SKIP')
+validpgpkeys=('A1EB079B8D3EB92B4EBD3139663AF51BD5E4D8D5') # Brent Cook <bcook@openbsd.org>
+
+build() {
+cd $srcdir/libressl-${pkgver}/
+./configure --prefix=/usr --sysconfdir=/etc --localstatedir=/var --enable-nc --enable-static --with-pic=nc
+make
+}
+
+package() {
+cd $srcdir/libressl-${pkgver}
+mkdir -p $pkgdir/usr/bin
+install -m 755 ./apps/nc/.libs/nc $pkgdir/usr/bin/nc
+mkdir -p $pkgdir/usr/lib
+install -m 644 ./tls/.libs/libtls.so.11 $pkgdir/usr/lib/libtls.so.11
+install -m 644 ./crypto/.libs/libcrypto.so.38 $pkgdir/usr/lib/libcrypto.so.38
+mkdir -p $pkgdir/usr/share/man/man1
+gzip -c ./apps/nc/nc.1 > $pkgdir/usr/share/man/man1/nc.1.gz
+}
+