summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPatrick Burroughs (Celti)2016-05-16 10:52:18 -0700
committerPatrick Burroughs (Celti)2016-05-16 10:52:18 -0700
commitb24b3c5f30678a14d7394e69142e7ab8f19c58f0 (patch)
tree413dc4e20442b996bf2e99111830e36c4c08d206
parent00f33d6d691f707ad39ac0c122d8243b2af0be08 (diff)
downloadaur-b24b3c5f30678a14d7394e69142e7ab8f19c58f0.tar.gz
Overhaul
-rw-r--r--PKGBUILD50
1 files changed, 18 insertions, 32 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 6d262ac8a70c..4e9b0e66dcf1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,60 +1,46 @@
# $Id: pkgbuild-mode.el,v 1.23 2007/10/20 16:02:14 juergen Exp $
# Maintainer: Alexandre BIQUE <bique.alexandre@gmail.com>
+# (Co-)Maintainer: Patrick Burroughs (Celti) <celti@celti.name>
+
pkgname=libreswan
pkgver=3.17
-pkgrel=1
+pkgrel=2
pkgdesc="IPsec implementation with IKEv1 and IKEv2 keying protocols"
arch=('i686' 'x86_64')
url="https://libreswan.org/"
-license=('GPLv2')
-groups=()
-depends=(unbound nss libcap-ng curl)
+license=('GPL' 'MPL')
+depends=('systemd' 'unbound' 'nss' 'libcap-ng' 'curl')
makedepends=('docbook-xsl' 'xmlto' 'flex' 'bison')
-checkdepends=()
-optdepends=()
-provides=()
conflicts=('freeswan' 'openswan' 'strongswan' 'ipsec-tools')
-replaces=()
backup=('etc/ipsec.conf' 'etc/ipsec.secrets' 'etc/pam.d/pluto')
-options=()
-install=
-changelog=
source=(https://download.libreswan.org/${pkgname}-${pkgver}.tar.gz
tmpfiles.conf)
-md5sums=('a37ce71229d491f30926788565f82e16'
- '77399a739ee99f8bc54837684d7c39d5')
-
-prepare() {
- cd $pkgname-$pkgver
-
- # Change install paths to Arch defaults
- sed -i 's|)/sbin|)/bin|' Makefile.inc
- sed -i 's|)/sbin|)/bin|' mk/config.mk
-}
+sha256sums=('28c286f57f6d8d00e1502ea283aac0f9f863edb2d759e50dc89df0e28c0d0d03'
+ '78265c690d58228c3bcc1a8793456172c39d493d268e9d9b1816288d0a47f573')
build() {
cd $pkgname-$pkgver
+ # Disable new warning introduced with GCC 6 (-Wunused-const-variable=)
+ export CFLAGS="$CFLAGS -Wno-error=unused-const-variable "
+
make \
- USE_XAUTH=true USE_LIBCAP_NG=true INC_USRLOCAL=/usr \
- USE_LEAK_DETECTIVE=false INC_MANDIR=share/man \
+ USE_XAUTH=true USE_LIBCAP_NG=true USE_LEAK_DETECTIVE=false \
+ INC_USRLOCAL=/usr INC_MANDIR=share/man \
+ FINALSBINDIR=/usr/bin FINALLIBEXECDIR=/usr/lib/ipsec \
programs
}
-# check() {
-# cd $pkgname-$pkgver
-
-# make -k check
-# }
-
package() {
cd $pkgname-$pkgver
make DESTDIR="$pkgdir/" \
- USE_XAUTH=true USE_LIBCAP_NG=true INC_USRLOCAL=/usr \
- USE_LEAK_DETECTIVE=false INC_MANDIR=share/man \
+ USE_XAUTH=true USE_LIBCAP_NG=true USE_LEAK_DETECTIVE=false \
+ INC_USRLOCAL=/usr INC_MANDIR=share/man \
+ FINALSBINDIR=/usr/bin FINALLIBEXECDIR=/usr/lib/ipsec \
install
- sed -i '1s|python|python2|' $pkgdir/usr/libexec/ipsec/verify
+
+ sed -i '1s|python|python2|' $pkgdir/usr/lib/ipsec/verify
install -D -m644 ${srcdir}/tmpfiles.conf ${pkgdir}/usr/lib/tmpfiles.d/libreswan.conf
rm -rf ${pkgdir}/var
}