summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorOliver Jaksch2016-03-06 06:31:31 +0100
committerOliver Jaksch2016-03-06 06:31:31 +0100
commita75947b6ee340c4bdf4539394fb18285877d9207 (patch)
tree517ab9ff76e6f2bc899940b8ea47eb57767ae8a8
downloadaur-a75947b6ee340c4bdf4539394fb18285877d9207.tar.gz
Initial commit
-rw-r--r--.SRCINFO26
-rw-r--r--PKGBUILD40
-rw-r--r--atari800_libretro.info18
-rw-r--r--cfg.patch17
-rw-r--r--joycfg.patch37
5 files changed, 138 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..1aa7be2adb8c
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,26 @@
+# Generated by mksrcinfo v8
+# Sun Mar 6 05:31:24 UTC 2016
+pkgbase = libretro-atari800-git
+ pkgdesc = libretro implementation of Atari800 v3.1.0 (Atari 5200/400/800/XL/XE) (WIP)
+ pkgver = 15.6e1883b
+ pkgrel = 1
+ url = https://github.com/r-type/libretro-atari800.git
+ arch = i686
+ arch = x86_64
+ arch = arm
+ arch = armv6h
+ arch = armv7h
+ license = GPL2
+ makedepends = git
+ depends = zlib
+ source = git+https://github.com/r-type/libretro-atari800.git
+ source = atari800_libretro.info
+ source = cfg.patch
+ source = joycfg.patch
+ sha256sums = SKIP
+ sha256sums = f482663fa58468d889e615909ba9e09d2e616300a9575338b86ce1b93d751bdb
+ sha256sums = 41e0c608d07cdc3228d37a7a29fd40b6629e964c13d14ba413fa84e956ef3777
+ sha256sums = d30794556b622c757dbafb5ce988547967004bd2d779c74e28802f9dd78a167f
+
+pkgname = libretro-atari800-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3c320e626313
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,40 @@
+# Maintainer: Oliver Jaksch <arch-aur@com-in.de>
+
+pkgname=libretro-atari800-git
+pkgver=15.6e1883b
+pkgrel=1
+pkgdesc="libretro implementation of Atari800 v3.1.0 (Atari 5200/400/800/XL/XE) (WIP)"
+arch=('i686' 'x86_64' 'arm' 'armv6h' 'armv7h')
+url="https://github.com/r-type/libretro-atari800.git"
+license=('GPL2')
+depends=('zlib')
+makedepends=('git')
+
+_libname=atari800_libretro
+_gitname=libretro-atari800
+source=("git+https://github.com/r-type/${_gitname}.git"
+ "${_libname}.info"
+ "cfg.patch"
+ "joycfg.patch")
+sha256sums=('SKIP'
+ 'f482663fa58468d889e615909ba9e09d2e616300a9575338b86ce1b93d751bdb'
+ '41e0c608d07cdc3228d37a7a29fd40b6629e964c13d14ba413fa84e956ef3777'
+ 'd30794556b622c757dbafb5ce988547967004bd2d779c74e28802f9dd78a167f')
+
+pkgver() {
+ cd "${_gitname}"
+ echo $(git rev-list --count HEAD).$(git rev-parse --short HEAD)
+}
+
+build() {
+ cd ${_gitname}
+ # rename config file to not interfere with original atari800
+ patch -p0 < "../cfg.patch"
+ patch -p0 < "../joycfg.patch"
+ make -f Makefile
+}
+
+package() {
+ install -Dm644 "${_gitname}/${_libname}.so" "${pkgdir}/usr/lib/libretro/${_libname}.so"
+ install -Dm644 "${_libname}.info" "${pkgdir}/usr/lib/libretro/${_libname}.info"
+}
diff --git a/atari800_libretro.info b/atari800_libretro.info
new file mode 100644
index 000000000000..15fc5d74f979
--- /dev/null
+++ b/atari800_libretro.info
@@ -0,0 +1,18 @@
+display_name = "Atari 5200/400/800/XL/XE (Atari800)"
+authors = "Petr Stehlik"
+supported_extensions = "xfd|atr|cdm|cas|bin|a52|zip"
+corename = "Atari800"
+manufacturer = "Atari"
+categories = "Emulator"
+systemname = "Atari 5200/400/800/XL/XE"
+license = "GPLv2"
+permissions = ""
+display_version = "3.1.0"
+supports_no_game = "false"
+firmware_count = 2
+firmware0_desc = "ATARIOSB.ROM (Atari OS-B image file)"
+firmware0_path = "ATARIOSB.ROM"
+firmware0_opt = "false"
+firmware1_desc = "ATARIXL.ROM (Atari-XL image file)"
+firmware1_path = "ATARIXL.ROM"
+firmware1_opt = "false"
diff --git a/cfg.patch b/cfg.patch
new file mode 100644
index 000000000000..89779f2c0503
--- /dev/null
+++ b/cfg.patch
@@ -0,0 +1,17 @@
+diff -uNr atari800.orig/src/cfg.c atari800/src/cfg.c
+--- atari800.orig/src/cfg.c 2016-02-23 14:28:55.247008447 +0100
++++ atari800/src/cfg.c 2016-02-23 14:29:07.360269454 +0100
+@@ -68,11 +68,11 @@
+ /* If another default path config path is defined use it
+ otherwise use the default one */
+ #ifndef DEFAULT_CFG_NAME
+-#define DEFAULT_CFG_NAME ".atari800.cfg"
++#define DEFAULT_CFG_NAME ".atari800.cfg.libretro"
+ #endif
+
+ #ifndef SYSTEM_WIDE_CFG_FILE
+-#define SYSTEM_WIDE_CFG_FILE "/etc/atari800.cfg"
++#define SYSTEM_WIDE_CFG_FILE "/etc/atari800.cfg.libretro"
+ #endif
+
+ static char rtconfig_filename[FILENAME_MAX];
diff --git a/joycfg.patch b/joycfg.patch
new file mode 100644
index 000000000000..81368c2661be
--- /dev/null
+++ b/joycfg.patch
@@ -0,0 +1,37 @@
+diff -uNr atari800.orig/src/joycfg.c atari800/src/joycfg.c
+--- atari800.orig/src/joycfg.c 2016-02-23 14:17:28.000000000 +0100
++++ atari800/src/joycfg.c 2016-02-23 14:24:09.282074155 +0100
+@@ -434,7 +434,7 @@
+ int i,no;
+ int bad=0;
+
+- if ((fr=fopen("atari800.cfg","r"))==NULL)
++ if ((fr=fopen("atari800.cfg.libretro","r"))==NULL)
+ {
+ printf("Error opening configuration file.\n"
+ "Execute this utility from atari800 dir after configuring it!\n");
+@@ -494,9 +494,9 @@
+ char string[256];
+ int i;
+
+- if ((fr=fopen("atari800.cfg","r"))==NULL)
++ if ((fr=fopen("atari800.cfg.libretro","r"))==NULL)
+ {
+- printf("Error opening atari800.cfg!\n");
++ printf("Error opening atari800.cfg.libretro!\n");
+ return;
+ }
+ if ((fw=fopen("atari800.tmp","w"))==NULL)
+@@ -521,10 +521,10 @@
+ for (i=0;i<4;i++)
+ fprintf(fw,"JOYSTICK_%i=%s\n",i,joyparams[joytypes[i]]);
+ fclose(fw);
+- if (rename("atari800.tmp","atari800.cfg")==0)
++ if (rename("atari800.tmp","atari800.cfg.libretro")==0)
+ printf("Configuration successfully saved.\n");
+ else
+- printf("Error when renaming atari800.tmp to atari800.cfg!\n");
++ printf("Error when renaming atari800.tmp to atari800.cfg.libretro!\n");
+ }
+ /*------------------------------------------------------------------------*/
+ int main()