summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlexandre Bouvier2022-03-12 23:28:54 +0100
committerAlexandre Bouvier2022-03-12 23:28:54 +0100
commit95c0e86a609cdc4206fafd6c71171405872990b8 (patch)
treeac388ddf48e0d8d444101a4294fedb446d22c9b3
parentfe8d2c4cf56069c725784e8eeff8b32172dc10f4 (diff)
downloadaur-95c0e86a609cdc4206fafd6c71171405872990b8.tar.gz
update to r734.26d9469
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD38
2 files changed, 33 insertions, 20 deletions
diff --git a/.SRCINFO b/.SRCINFO
index db0bef00d2f3..0a600f777c9c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,22 @@
pkgbase = libretro-beetle-lynx-git
pkgdesc = Atari Lynx core
- pkgver = r707.c1d9f1e
+ pkgver = r734.26d9469
pkgrel = 1
url = https://github.com/libretro/beetle-lynx-libretro
+ arch = aarch64
+ arch = arm
+ arch = armv6h
+ arch = armv7h
+ arch = i686
arch = x86_64
- groups = libretro-unstable
+ groups = libretro
license = GPL2
makedepends = git
+ depends = gcc-libs
depends = libretro-core-info
+ provides = libretro-beetle-lynx
+ conflicts = libretro-beetle-lynx
source = libretro-beetle-lynx::git+https://github.com/libretro/beetle-lynx-libretro.git
- sha256sums = SKIP
+ b2sums = SKIP
pkgname = libretro-beetle-lynx-git
-
diff --git a/PKGBUILD b/PKGBUILD
index b867d8592c1b..accb379af4ff 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,29 +1,35 @@
-# Maintainer: Daniel Menelkir <menelkir@itroll.org>
-
-pkgname=libretro-beetle-lynx-git
-pkgver=r707.c1d9f1e
+# Maintainer: Alexandre Bouvier <contact@amb.tf>
+# Contributor: Daniel Menelkir <menelkir@itroll.org>
+_pkgname=libretro-beetle-lynx
+pkgname=$_pkgname-git
+pkgver=r734.26d9469
pkgrel=1
-pkgdesc='Atari Lynx core'
-arch=('x86_64')
-url='https://github.com/libretro/beetle-lynx-libretro'
+pkgdesc="Atari Lynx core"
+arch=('aarch64' 'arm' 'armv6h' 'armv7h' 'i686' 'x86_64')
+url="https://github.com/libretro/beetle-lynx-libretro"
license=('GPL2')
-groups=('libretro-unstable')
-depends=('libretro-core-info')
+groups=('libretro')
+depends=('gcc-libs' 'libretro-core-info')
makedepends=('git')
-source=("libretro-beetle-lynx::git+https://github.com/libretro/beetle-lynx-libretro.git")
-sha256sums=('SKIP')
+provides=("$_pkgname")
+conflicts=("$_pkgname")
+source=("$_pkgname::git+$url.git")
+b2sums=('SKIP')
pkgver() {
- cd libretro-beetle-lynx
+ cd $_pkgname
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
- echo "r$(git rev-list --count HEAD).$(git rev-parse --short HEAD)"
+prepare() {
+ sed -i 's/-O2//' $_pkgname/Makefile
}
build() {
- make -C libretro-beetle-lynx
+ make -C $_pkgname
}
package() {
- install -Dm 644 libretro-beetle-lynx/mednafen_lynx_libretro.so -t "${pkgdir}"/usr/lib/libretro/
+ # shellcheck disable=SC2154
+ make -C $_pkgname DESTDIR="$pkgdir" install
}
-