summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBenjamin Hodgetts2018-08-14 14:18:59 +0100
committerBenjamin Hodgetts2018-08-14 14:18:59 +0100
commit642e5f4810d0b6cbc3b7002e03df554686e89455 (patch)
tree07aee0ba872a7ff892b630b6f47a99b006aa710d
downloadaur-642e5f4810d0b6cbc3b7002e03df554686e89455.tar.gz
Initial commit
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD33
2 files changed, 51 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..24fce94d503b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = libretro-beetle-pcfx-git
+ pkgdesc = Mednafen PCFX libretro core (NEC PC-FX).
+ pkgver = r767.84b7ca6
+ pkgrel = 1
+ url = https://github.com/libretro/beetle-pcfx-libretro
+ arch = i686
+ arch = x86_64
+ groups = libretro
+ license = GPLv2
+ makedepends = git
+ depends = libretro-core-info
+ provides = libretro-beetle-pcfx
+ conflicts = libretro-beetle-pcfx
+ source = git+https://github.com/libretro/beetle-pcfx-libretro.git
+ md5sums = SKIP
+
+pkgname = libretro-beetle-pcfx-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8a3990a500a9
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: Benjamin Hodgetts <ben@xnode.org>
+
+_libname=mednafen_pcfx_libretro
+_gitname=beetle-pcfx-libretro
+pkgname=libretro-beetle-pcfx-git
+pkgver=r767.84b7ca6
+pkgrel=1
+pkgdesc="Mednafen PCFX libretro core (NEC PC-FX)."
+arch=('i686' 'x86_64')
+url="https://github.com/libretro/beetle-pcfx-libretro"
+license=('GPLv2')
+groups=('libretro')
+depends=('libretro-core-info')
+makedepends=('git')
+groups=('libretro')
+provides=('libretro-beetle-pcfx')
+conflicts=('libretro-beetle-pcfx')
+source=("git+https://github.com/libretro/${_gitname}.git")
+md5sums=('SKIP')
+
+pkgver() {
+ cd "${_gitname}"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd "${_gitname}"
+ make
+}
+
+package() {
+ install -Dm644 "${_gitname}/${_libname}.so" "${pkgdir}/usr/lib/libretro/${_libname}.so"
+}