summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlexandre Bouvier2023-06-09 22:22:23 +0200
committerAlexandre Bouvier2023-06-09 22:22:23 +0200
commit714e164481aadae89991db6ceca9c527e5a9d03f (patch)
treeb23721ecc6fb65b566459cfb47cdd08b09dc1544
parentf39f62028a6fb46fc04199cac67bdcc3fffe6eb0 (diff)
downloadaur-714e164481aadae89991db6ceca9c527e5a9d03f.tar.gz
update to r3087.3c186825
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD60
-rw-r--r--libretro-bsnes-flags.patch24
3 files changed, 39 insertions, 67 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 88aafb1e551a..bbe0c6ac44a6 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,19 +1,23 @@
pkgbase = libretro-bsnes-git
- pkgdesc = Super Nintendo Entertainment System cores
- pkgver = r3048.44d97b17
+ pkgdesc = Super Nintendo Entertainment System core
+ pkgver = r3087.3c186825
pkgrel = 1
- url = https://github.com/libretro/bsnes
+ url = https://github.com/libretro/bsnes-libretro
+ arch = aarch64
+ arch = armv7h
+ arch = i486
+ arch = i686
+ arch = pentium4
arch = x86_64
- groups = libretro-unstable
+ groups = libretro
license = GPL3
makedepends = git
depends = gcc-libs
+ depends = glibc
depends = libretro-core-info
- provides = libretro-bsnes
+ provides = libretro-bsnes=1:3087.3c186825
conflicts = libretro-bsnes
- source = libretro-bsnes::git+https://github.com/libretro/bsnes-libretro
- source = libretro-bsnes-flags.patch
- sha256sums = SKIP
- sha256sums = 3e1704ba3e7175330a0e291fbeb1e0bee18518ac29a2008d984585fb7a9b887c
+ source = libretro-bsnes::git+https://github.com/libretro/bsnes-libretro.git
+ b2sums = SKIP
pkgname = libretro-bsnes-git
diff --git a/PKGBUILD b/PKGBUILD
index 4299a030c48c..b9657f705d1b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,48 +1,40 @@
-# Maintainer: Anthony Wang <ta180m@pm.me>
+# Maintainer: Alexandre Bouvier <contact@amb.tf>
+# Contributor: Anthony Wang <ta180m@pm.me>
# Contributor: Maxime Gauduin <alucryd@archlinux.org>
-
-pkgname=libretro-bsnes-git
-pkgver=r3048.44d97b17
+_pkgname=libretro-bsnes
+pkgname=$_pkgname-git
+pkgver=r3087.3c186825
pkgrel=1
-pkgdesc='Super Nintendo Entertainment System cores'
-arch=(x86_64)
-url=https://github.com/libretro/bsnes
-license=(GPL3)
-groups=(libretro-unstable)
-depends=(
- gcc-libs
- libretro-core-info
-)
-makedepends=(git)
-provides=(libretro-bsnes)
-conflicts=(libretro-bsnes)
-source=(
- libretro-bsnes::git+https://github.com/libretro/bsnes-libretro
- libretro-bsnes-flags.patch
-)
-sha256sums=(
- SKIP
- 3e1704ba3e7175330a0e291fbeb1e0bee18518ac29a2008d984585fb7a9b887c
-)
+pkgdesc="Super Nintendo Entertainment System core"
+arch=('aarch64' 'armv7h' 'i486' 'i686' 'pentium4' 'x86_64')
+url="https://github.com/libretro/bsnes-libretro"
+license=('GPL3')
+groups=('libretro')
+depends=('gcc-libs' 'glibc' 'libretro-core-info')
+makedepends=('git')
+provides=("$_pkgname=1:${pkgver#r}")
+conflicts=("$_pkgname")
+source=("$_pkgname::git+$url.git")
+b2sums=('SKIP')
pkgver() {
- cd libretro-bsnes
-
- echo "r$(git rev-list --count HEAD).$(git rev-parse --short HEAD)"
+ cd $_pkgname
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
prepare() {
- cd libretro-bsnes
-
- patch -Np1 -i ../libretro-bsnes-flags.patch
+ cd $_pkgname
+ sed -i 's/-O3//' nall/GNUmakefile
+ sed -i '1i #include <stdexcept>' nall/arithmetic/natural.hpp
}
build() {
- make -C libretro-bsnes/bsnes target=libretro binary=library local=false platform=linux
+ export flags+=" $CXXFLAGS"
+ export options+=" $LDFLAGS"
+ make -C $_pkgname/bsnes target=libretro binary=library local=false platform=linux
}
package() {
- install -Dm 644 libretro-bsnes/bsnes/out/bsnes_libretro.so -t "${pkgdir}"/usr/lib/libretro/
+ # shellcheck disable=SC2154
+ install -D -t "$pkgdir"/usr/lib/libretro $_pkgname/bsnes/out/bsnes_libretro.so
}
-
-# vim: ts=2 sw=2 et:
diff --git a/libretro-bsnes-flags.patch b/libretro-bsnes-flags.patch
deleted file mode 100644
index a23ae38448a3..000000000000
--- a/libretro-bsnes-flags.patch
+++ /dev/null
@@ -1,24 +0,0 @@
-From 6d0f100d25fecae89a48c76f55371730a51c10fe Mon Sep 17 00:00:00 2001
-From: Maxime Gauduin <alucryd@archlinux.org>
-Date: Wed, 18 Mar 2020 17:08:25 +0100
-Subject: [PATCH] use system flags
-
----
- nall/GNUmakefile | 3 ++-
- 1 file changed, 2 insertions(+), 1 deletion(-)
-
-diff --git a/nall/GNUmakefile b/nall/GNUmakefile
-index 67fb3a15..fddec93d 100755
---- a/nall/GNUmakefile
-+++ b/nall/GNUmakefile
-@@ -127,7 +127,8 @@ endif
-
- # linux settings
- ifeq ($(platform),linux)
-- options += -ldl
-+ flags += ${CXXFLAGS}
-+ options += ${LDFLAGS} -ldl
- endif
-
- # bsd settings
-