summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMaxime Gauduin2015-08-27 12:16:52 +0200
committerMaxime Gauduin2015-08-27 12:16:52 +0200
commitb124ec61e7989af5b889ecc4742f9388b7da51d9 (patch)
treecfcb8f1906700027994839cec1d3a6a12d02ee5f
downloadaur-b124ec61e7989af5b889ecc4742f9388b7da51d9.tar.gz
Initial import
-rw-r--r--.SRCINFO23
-rw-r--r--MKPKG5
-rw-r--r--PKGBUILD46
3 files changed, 74 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e1399c954f88
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,23 @@
+pkgbase = libretro-bsnes-git
+ pkgdesc = bsnes libretro core
+ pkgver = r457.1f9f61a
+ pkgrel = 1
+ url = https://github.com/libretro/bsnes-libretro
+ arch = i686
+ arch = x86_64
+ groups = libretro
+ license = GPL3
+ makedepends = git
+ depends = gcc-libs
+ depends = glibc
+ source = libretro-bsnes::git+https://github.com/libretro/bsnes-libretro
+ source = https://raw.githubusercontent.com/libretro/libretro-super/master/dist/info/bsnes_accuracy_libretro.info
+ source = https://raw.githubusercontent.com/libretro/libretro-super/master/dist/info/bsnes_balanced_libretro.info
+ source = https://raw.githubusercontent.com/libretro/libretro-super/master/dist/info/bsnes_performance_libretro.info
+ sha256sums = SKIP
+ sha256sums = 6a70cd34b75217c1b7e23ebba16e13b80bbda1c2370b5f2fcd83a99bfdc5b3e0
+ sha256sums = 444ed721643530446ff7dd93ff0fec24e1f53eff3a93524b4649593ba23e2e2f
+ sha256sums = 42e4369171f6aba98d389f6b097a561e225b9fcd63f0587fd75f0e57b580198f
+
+pkgname = libretro-bsnes-git
+
diff --git a/MKPKG b/MKPKG
new file mode 100644
index 000000000000..569b657cab32
--- /dev/null
+++ b/MKPKG
@@ -0,0 +1,5 @@
+pkgname=('libretro-bsnes-git')
+
+check_git $packagedir/$pkgname/${pkgname%-*}
+
+# vim: ts=2 sw=2 et:
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..779ca539265b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,46 @@
+# Maintainer: Maxime Gauduin <alucryd@archlinux.org>
+
+pkgname=libretro-bsnes-git
+pkgver=r457.1f9f61a
+pkgrel=1
+pkgdesc='bsnes libretro core'
+arch=('i686' 'x86_64')
+url='https://github.com/libretro/bsnes-libretro'
+license=('GPL3')
+groups=('libretro')
+depends=('gcc-libs' 'glibc')
+makedepends=('git')
+source=('libretro-bsnes::git+https://github.com/libretro/bsnes-libretro'
+ 'https://raw.githubusercontent.com/libretro/libretro-super/master/dist/info/bsnes_accuracy_libretro.info'
+ 'https://raw.githubusercontent.com/libretro/libretro-super/master/dist/info/bsnes_balanced_libretro.info'
+ 'https://raw.githubusercontent.com/libretro/libretro-super/master/dist/info/bsnes_performance_libretro.info')
+sha256sums=('SKIP'
+ '6a70cd34b75217c1b7e23ebba16e13b80bbda1c2370b5f2fcd83a99bfdc5b3e0'
+ '444ed721643530446ff7dd93ff0fec24e1f53eff3a93524b4649593ba23e2e2f'
+ '42e4369171f6aba98d389f6b097a561e225b9fcd63f0587fd75f0e57b580198f')
+
+pkgver() {
+ cd libretro-bsnes
+
+ echo "r$(git rev-list --count HEAD).$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd libretro-bsnes
+
+ for p in accuracy balanced performance; do
+ make profile=${p}
+ done
+}
+
+package() {
+ cd libretro-bsnes
+
+ install -dm 755 "${pkgdir}"/usr/{lib/libretro,share/libretro/info}
+ for p in accuracy balanced performance; do
+ install -m 644 out/bsnes_${p}_libretro.so "${pkgdir}"/usr/lib/libretro/
+ install -m 644 ../bsnes_${p}_libretro.info "${pkgdir}"/usr/share/libretro/info/
+ done
+}
+
+# vim: ts=2 sw=2 et: