summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAnthony Wang2021-11-28 15:07:13 -0600
committerAnthony Wang2021-11-28 15:07:13 -0600
commitf39f62028a6fb46fc04199cac67bdcc3fffe6eb0 (patch)
tree1c65ad4ef63d55849c0c210130cce8b51e3aa39a
parent70e378569f2e8b948cde5445c1c12ededfe05547 (diff)
downloadaur-f39f62028a6fb46fc04199cac67bdcc3fffe6eb0.tar.gz
Update PKGBUILD to match libretro-bsnes in community
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD49
-rw-r--r--libretro-bsnes-flags.patch24
3 files changed, 53 insertions, 30 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6fb8f9cff848..88aafb1e551a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,21 +1,19 @@
-# Generated by mksrcinfo v8
-# Fri Dec 22 13:58:38 UTC 2017
pkgbase = libretro-bsnes-git
pkgdesc = Super Nintendo Entertainment System cores
- pkgver = r543.a4800add
+ pkgver = r3048.44d97b17
pkgrel = 1
- url = https://github.com/libretro/bsnes-libretro
+ url = https://github.com/libretro/bsnes
arch = x86_64
groups = libretro-unstable
license = GPL3
makedepends = git
depends = gcc-libs
- depends = glibc
depends = libretro-core-info
provides = libretro-bsnes
conflicts = libretro-bsnes
source = libretro-bsnes::git+https://github.com/libretro/bsnes-libretro
+ source = libretro-bsnes-flags.patch
sha256sums = SKIP
+ sha256sums = 3e1704ba3e7175330a0e291fbeb1e0bee18518ac29a2008d984585fb7a9b887c
pkgname = libretro-bsnes-git
-
diff --git a/PKGBUILD b/PKGBUILD
index a1a1e494b8cf..4299a030c48c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,19 +1,29 @@
-# Maintainer: Maxime Gauduin <alucryd@archlinux.org>
+# Maintainer: Anthony Wang <ta180m@pm.me>
+# Contributor: Maxime Gauduin <alucryd@archlinux.org>
pkgname=libretro-bsnes-git
-pkgver=r543.a4800add
+pkgver=r3048.44d97b17
pkgrel=1
pkgdesc='Super Nintendo Entertainment System cores'
-arch=('x86_64')
-url='https://github.com/libretro/bsnes-libretro'
-license=('GPL3')
-groups=('libretro-unstable')
-depends=('gcc-libs' 'glibc' 'libretro-core-info')
-makedepends=('git')
-provides=('libretro-bsnes')
-conflicts=('libretro-bsnes')
-source=('libretro-bsnes::git+https://github.com/libretro/bsnes-libretro')
-sha256sums=('SKIP')
+arch=(x86_64)
+url=https://github.com/libretro/bsnes
+license=(GPL3)
+groups=(libretro-unstable)
+depends=(
+ gcc-libs
+ libretro-core-info
+)
+makedepends=(git)
+provides=(libretro-bsnes)
+conflicts=(libretro-bsnes)
+source=(
+ libretro-bsnes::git+https://github.com/libretro/bsnes-libretro
+ libretro-bsnes-flags.patch
+)
+sha256sums=(
+ SKIP
+ 3e1704ba3e7175330a0e291fbeb1e0bee18518ac29a2008d984585fb7a9b887c
+)
pkgver() {
cd libretro-bsnes
@@ -24,24 +34,15 @@ pkgver() {
prepare() {
cd libretro-bsnes
- sed 's/g++-4.9/g++/g' -i nall/Makefile
+ patch -Np1 -i ../libretro-bsnes-flags.patch
}
build() {
- cd libretro-bsnes
-
- for p in accuracy balanced performance; do
- make profile=${p}
- done
+ make -C libretro-bsnes/bsnes target=libretro binary=library local=false platform=linux
}
package() {
- cd libretro-bsnes
-
- install -dm 755 "${pkgdir}"/usr/{lib/libretro,share/libretro/info}
- for p in accuracy balanced performance; do
- install -m 644 out/bsnes_${p}_libretro.so "${pkgdir}"/usr/lib/libretro/
- done
+ install -Dm 644 libretro-bsnes/bsnes/out/bsnes_libretro.so -t "${pkgdir}"/usr/lib/libretro/
}
# vim: ts=2 sw=2 et:
diff --git a/libretro-bsnes-flags.patch b/libretro-bsnes-flags.patch
new file mode 100644
index 000000000000..a23ae38448a3
--- /dev/null
+++ b/libretro-bsnes-flags.patch
@@ -0,0 +1,24 @@
+From 6d0f100d25fecae89a48c76f55371730a51c10fe Mon Sep 17 00:00:00 2001
+From: Maxime Gauduin <alucryd@archlinux.org>
+Date: Wed, 18 Mar 2020 17:08:25 +0100
+Subject: [PATCH] use system flags
+
+---
+ nall/GNUmakefile | 3 ++-
+ 1 file changed, 2 insertions(+), 1 deletion(-)
+
+diff --git a/nall/GNUmakefile b/nall/GNUmakefile
+index 67fb3a15..fddec93d 100755
+--- a/nall/GNUmakefile
++++ b/nall/GNUmakefile
+@@ -127,7 +127,8 @@ endif
+
+ # linux settings
+ ifeq ($(platform),linux)
+- options += -ldl
++ flags += ${CXXFLAGS}
++ options += ${LDFLAGS} -ldl
+ endif
+
+ # bsd settings
+