summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMaxime Gauduin2017-12-22 14:48:43 +0100
committerMaxime Gauduin2017-12-22 14:48:43 +0100
commit21fe71b2b94a15f8aa7de72ec47c8da2f290ca38 (patch)
tree125fa898e1153ea4d6ce860b052dd217c39cb5dc
downloadaur-21fe71b2b94a15f8aa7de72ec47c8da2f290ca38.tar.gz
Add libretro-core-info-git
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD29
2 files changed, 47 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..9536cf55b8a2
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+# Generated by mksrcinfo v8
+# Fri Dec 22 13:48:42 UTC 2017
+pkgbase = libretro-core-info-git
+ pkgdesc = Libretro core info files
+ pkgver = r27.500790e
+ pkgrel = 1
+ url = https://github.com/libretro/libretro-core-info
+ arch = any
+ groups = libretro-unstable
+ license = GPL3
+ makedepends = git
+ provides = libretro-core-info
+ conflicts = libretro-core-info
+ source = git+https://github.com/libretro/libretro-core-info.git
+ sha256sums = SKIP
+
+pkgname = libretro-core-info-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7f939f14c06f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: Maxime Gauduin <alucryd@archlinux.org>
+
+pkgname=libretro-core-info-git
+pkgver=r27.500790e
+pkgrel=1
+pkgdesc='Libretro core info files'
+arch=('any')
+url='https://github.com/libretro/libretro-core-info'
+license=('GPL3')
+groups=('libretro-unstable')
+makedepends=('git')
+provides=('libretro-core-info')
+conflicts=('libretro-core-info')
+source=('git+https://github.com/libretro/libretro-core-info.git')
+sha256sums=('SKIP')
+
+pkgver() {
+ cd libretro-core-info
+
+ echo "r$(git rev-list --count HEAD).$(git rev-parse --short HEAD)"
+}
+
+package() {
+ cd libretro-core-info
+
+ make DESTDIR="${pkgdir}" install
+}
+
+# vim: ts=2 sw=2 et: