summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMaxime Gauduin2017-06-22 21:12:27 +0200
committerMaxime Gauduin2017-06-22 21:12:27 +0200
commitb995d8efb4f77cb82878fb53ea695f3f997d90da (patch)
treea7a8b7b7b329e5b78c1ae9b3337e5b60aae836cc
downloadaur-b995d8efb4f77cb82878fb53ea695f3f997d90da.tar.gz
Add libretro-dolphin-git
-rw-r--r--.SRCINFO23
-rw-r--r--PKGBUILD39
2 files changed, 62 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..11325ddc0fa2
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,23 @@
+# Generated by mksrcinfo v8
+# Thu Jun 22 19:12:26 UTC 2017
+pkgbase = libretro-dolphin-git
+ pkgdesc = Nintendo GC/Wii core
+ pkgver = r23904.54445a0a87
+ pkgrel = 1
+ url = https://github.com/libretro/dolphin
+ arch = i686
+ arch = x86_64
+ groups = libretro
+ license = GPL2
+ makedepends = git
+ depends = gcc-libs
+ depends = glibc
+ provides = libretro-dolphin
+ conflicts = libretro-dolphin
+ source = libretro-dolphin::git+https://github.com/libretro/dolphin.git
+ source = git+https://github.com/libretro/libretro-core-info.git
+ sha256sums = SKIP
+ sha256sums = SKIP
+
+pkgname = libretro-dolphin-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e5f87ea4cb89
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,39 @@
+# Maintainer: Maxime Gauduin <alucryd@archlinux.org>
+
+pkgname=libretro-dolphin-git
+pkgver=r23904.54445a0a87
+pkgrel=1
+pkgdesc='Nintendo GC/Wii core'
+arch=('i686' 'x86_64')
+url='https://github.com/libretro/dolphin'
+license=('GPL2')
+groups=('libretro')
+depends=('gcc-libs' 'glibc')
+makedepends=('git')
+provides=('libretro-dolphin')
+conflicts=('libretro-dolphin')
+source=('libretro-dolphin::git+https://github.com/libretro/dolphin.git'
+ 'git+https://github.com/libretro/libretro-core-info.git')
+sha256sums=('SKIP'
+ 'SKIP')
+
+pkgver() {
+ cd libretro-dolphin
+
+ echo "r$(git rev-list --count HEAD).$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd libretro-dolphin/Source/Core/DolphinLibretro
+
+ make
+}
+
+package() {
+ cd libretro-dolphin/Source/Core/DolphinLibretro
+
+ install -Dm 644 dolphin_libretro.so -t "${pkgdir}"/usr/lib/libretro/
+ install -Dm 644 ../../../../libretro-core-info/dolphin_libretro.info -t "${pkgdir}"/usr/share/libretro/info/
+}
+
+# vim: ts=2 sw=2 et: