summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorOliver Jaksch2018-06-03 12:48:10 +0200
committerOliver Jaksch2018-06-03 12:48:10 +0200
commite42267d9e3bdf51c129f89c914b22ccb68f8310f (patch)
tree0abb32bde58b0c3850f638f845f863a8fb1729ee
downloadaur-e42267d9e3bdf51c129f89c914b22ccb68f8310f.tar.gz
Initial commit
-rw-r--r--.SRCINFO23
-rw-r--r--PKGBUILD33
2 files changed, 56 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b2ad7df0c23c
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,23 @@
+# Generated by mksrcinfo v8
+# Sun Jun 3 10:47:52 UTC 2018
+pkgbase = libretro-freeintv-git
+ pkgdesc = A libretro emulation core for the Mattel Intellivision designed to be compatible with joypads from the SNES era forward
+ pkgver = 92.233f362
+ pkgrel = 1
+ url = https://github.com/libretro/FreeIntv
+ arch = i686
+ arch = x86_64
+ arch = arm
+ arch = armv6h
+ arch = armv7h
+ groups = libretro
+ license = custom:zlib
+ makedepends = git
+ depends = zlib
+ depends = glibc
+ depends = libretro-core-info
+ source = git+https://github.com/libretro/FreeIntv.git
+ sha256sums = SKIP
+
+pkgname = libretro-freeintv-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5e3ce68e24d8
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: Oliver Jaksch <arch-aur@com-in.de>
+
+pkgname=libretro-freeintv-git
+pkgver=92.233f362
+pkgrel=1
+pkgdesc="A libretro emulation core for the Mattel Intellivision designed to be compatible with joypads from the SNES era forward"
+arch=('i686' 'x86_64' 'arm' 'armv6h' 'armv7h')
+url="https://github.com/libretro/FreeIntv"
+license=('custom:zlib')
+groups=('libretro')
+depends=('zlib' 'glibc' 'libretro-core-info')
+makedepends=('git')
+
+_libname=freeintv_libretro
+_gitname=FreeIntv
+source=("git+https://github.com/libretro/${_gitname}.git")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "${_gitname}"
+ echo $(git rev-list --count HEAD).$(git rev-parse --short HEAD)
+}
+
+build() {
+ cd "${_gitname}"
+ make
+}
+
+package() {
+ install -Dm644 "${_gitname}/${_libname}.so" "${pkgdir}/usr/lib/libretro/${_libname}.so"
+ install -Dm644 "${_gitname}/LICENSE" "${pkgdir}/usr/share/licenses/${pkgname}/license.txt"
+ msg2 "\e[1;32mFreeIntv requires Intellivision BIOS files 'exec.bin' and 'grom.bin' to be placed in the libretro 'system' folder. \e[0m"
+}